Bug 12619 - Shipment date gets lost on finishing the invoice
Summary: Shipment date gets lost on finishing the invoice
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Jacek Ablewicz
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-21 21:42 UTC by Katrin Fischer
Modified: 2015-12-03 22:00 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 12619 - Shipment date gets lost on finishing and/or editing the invoice (1.38 KB, patch)
2014-07-22 16:12 UTC, Jacek Ablewicz
Details | Diff | Splinter Review
Bug 12619 - Shipment date gets lost on finishing and/or editing the invoice (1.43 KB, patch)
2014-07-29 04:25 UTC, sandboxes@biblibre.com
Details | Diff | Splinter Review
[PASSED QA] Bug 12619 - Shipment date gets lost on finishing and/or editing the invoice (1.56 KB, patch)
2014-07-29 21:38 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2014-07-21 21:42:17 UTC
to reproduce:
- Create a new shipment, make sure to add a shipment date
- Receive or not receive orders
- Finish receiving with the button at the bottom of the page
- Verify that shipment date is now empty
Comment 1 Katrin Fischer 2014-07-22 07:49:23 UTC
Losing data you entered is not nice and could go unnoticed - upping severity a bit.
Comment 2 Jacek Ablewicz 2014-07-22 16:12:31 UTC Comment hidden (obsolete)
Comment 3 sandboxes@biblibre.com 2014-07-29 04:25:36 UTC
Patch tested with a sandbox, by Aleisha <aleishaamohia@hotmail.com>
Comment 4 sandboxes@biblibre.com 2014-07-29 04:25:53 UTC Comment hidden (obsolete)
Comment 5 Katrin Fischer 2014-07-29 21:38:55 UTC
Created attachment 30314 [details] [review]
[PASSED QA] Bug 12619 - Shipment date gets lost on finishing and/or editing the invoice

To reproduce:
- Create a new shipment, make sure to add a shipment date
- Receive or not receive orders
- Finish receiving with the button at the bottom of the page
- Verify that shipment date is now empty

To test:
- reproduce the aforementioned issue
- apply patch
- confirm that the issue is no longer rerpoductible (= shipment date is
not getting lost any longer), and that there are no apparent regresssions
of any kind involving invoice shipment date entering and/or editing
- sign off

Signed-off-by: Aleisha <aleishaamohia@hotmail.com>
Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Passes tests and QA script, fixes the issues, no problems found.
Comment 6 Tomás Cohen Arazi 2014-08-05 23:55:53 UTC
Patch pushed to master.

Thanks Jacek!
Comment 7 Galen Charlton 2014-09-23 04:59:19 UTC
Pushed to 3.16.x for inclusion in 3.16.4.
Comment 8 Fridolin Somers 2015-01-23 12:38:52 UTC
Looks like patch is not needs for 3.14.x, I set as resolved