Bug 12628 - reports/cat_issues_top.pl incorrect checkout range query
Summary: reports/cat_issues_top.pl incorrect checkout range query
Status: RESOLVED DUPLICATE of bug 17801
Alias: None
Product: Koha
Classification: Unclassified
Component: Reports (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Arthur Suzuki
QA Contact: Testopia
URL:
Keywords: Academy
Depends on:
Blocks:
 
Reported: 2014-07-22 17:32 UTC by Micah Bucy
Modified: 2020-09-03 09:18 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments
use issuedate instead of timestamp (2.01 KB, patch)
2014-07-22 17:32 UTC, Micah Bucy
Details | Diff | Splinter Review
Bug 12628: replace use of timestamp with issuedate in cat_issues_top (5.58 KB, patch)
2020-06-17 10:51 UTC, Arthur Suzuki
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Micah Bucy 2014-07-22 17:32:50 UTC
Created attachment 29958 [details] [review]
use issuedate instead of timestamp

When trying to filter by Checkout Date range, it mistakenly uses the timestamp column instead of the issuedate column.
Comment 1 Marc Véron 2016-10-03 16:17:37 UTC
Still valid?
Comment 2 Katrin Fischer 2019-03-11 23:28:20 UTC
(In reply to Marc Véron from comment #1)
> Still valid?

It looks like it is, but there are even more occurrences of timestamp in the file. The attached file is also not a valid patch format, still needs some work.
Comment 3 Katrin Fischer 2020-01-05 23:59:57 UTC
This might be a nice rescue bug.
Comment 4 Arthur Suzuki 2020-06-17 10:51:55 UTC
Created attachment 105942 [details] [review]
Bug 12628: replace use of timestamp with issuedate in cat_issues_top

test plan
    1) run cat_issues_top
    2) anonymise old issues (misc/cronjobs/batch_anonymise.pl)
    3) rerun and notice the figures changed!
    4) apply patch
    5) rerun and notice the figures are back to normal
Comment 5 Arthur Suzuki 2020-08-26 09:19:32 UTC
up?
Comment 6 Fridolin Somers 2020-09-03 09:18:01 UTC

*** This bug has been marked as a duplicate of bug 17801 ***