Bug 12629 - Software error when trying to merge records from different frameworks
Summary: Software error when trying to merge records from different frameworks
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low normal (vote)
Assignee: Kyle M Hall
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-22 22:12 UTC by Barton Chittenden
Modified: 2017-06-14 22:14 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Screen shot of record merge. (30.67 KB, image/png)
2014-07-22 22:12 UTC, Barton Chittenden
Details
Bug 12629 - Software error when trying to merge records from different frameworks (1.35 KB, patch)
2014-07-23 16:45 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 12629 - Software error when trying to merge records from different frameworks (1.42 KB, patch)
2016-09-09 01:27 UTC, Chris Cormack
Details | Diff | Splinter Review
Bug 12629 - Software error when trying to merge records from different frameworks (1.49 KB, patch)
2016-09-13 10:11 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Barton Chittenden 2014-07-22 22:12:25 UTC
Created attachment 29960 [details]
Screen shot of record merge.

Software error:

Can't use string ("") as a HASH ref while "strict refs" in use at /var/lib/koha/butte/kohaclone/Koha/Util/MARC.pm line 46.

To re-create:

Choose a bib record that has the default framework.

Add a second record using that fast add framework.

Merge the records; switch to "Using framework: Default", and choose the original record (i.e. the one that had the default framework) as the merge reference. Clicking 'Next' will trigger the error.

See attached screenshot.
Comment 1 Kyle M Hall 2014-07-23 16:45:00 UTC Comment hidden (obsolete)
Comment 2 Owen Leonard 2016-06-23 18:00:46 UTC
This bug has had a patch since 2014 but was never marked "Needs signoff!" However, I can't reproduce the problem in master. Is it still valid?
Comment 3 Jonathan Druart 2016-08-16 13:23:23 UTC
(In reply to Owen Leonard from comment #2)
> This bug has had a patch since 2014 but was never marked "Needs signoff!"
> However, I can't reproduce the problem in master. Is it still valid?

Looking at the code, I'd say it's still valid and appears when a field is defined in one framework but in the other one.
Comment 4 Chris Cormack 2016-09-09 01:27:22 UTC Comment hidden (obsolete)
Comment 5 Jonathan Druart 2016-09-13 07:48:23 UTC
I do not recreate the error. Is there something missing in the test plan?
Comment 6 Zeno Tajoli 2016-09-13 08:39:41 UTC
Try to test using 006 or 007 in record with 'Default' framework.
Tags 006 and 007 are nt defined in FA framework and are minus than 10.
Comment 7 Jonathan Druart 2016-09-13 10:11:07 UTC
Created attachment 55525 [details] [review]
Bug 12629 - Software error when trying to merge records from different frameworks

Test Plan:
1) Choose a bib record that has the default framework.
2) Add a second record using that fast add framework.
3) Merge the records; switch to "Using framework: Default", and choose the original record (i.e. the one that had the default framework) as the merge reference. Clicking 'Next' will trigger the error.
4) Apply this patch
5) Repeat steps 1 - 3, no error should occur

Signed-off-by: Chris Cormack <chrisc@catalyst.net.nz>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 8 Jonathan Druart 2016-09-13 10:11:44 UTC
(In reply to Zeno Tajoli from comment #6)
> Try to test using 006 or 007 in record with 'Default' framework.
> Tags 006 and 007 are nt defined in FA framework and are minus than 10.

Indeed, thanks!
Comment 9 Kyle M Hall 2016-09-15 13:45:24 UTC
Pushed to master for 16.11!
Comment 10 Frédéric Demians 2016-09-15 15:09:38 UTC
Pushed in 16.05. Will be in 16.05.04.
Comment 11 Julian Maurice 2016-09-16 10:05:07 UTC
Pushed to 3.22.x, will be in 3.22.11