Bug 12711 - Add support to new protocols
Summary: Add support to new protocols
Status: RESOLVED DUPLICATE of bug 6536
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low new feature (vote)
Assignee: Galen Charlton
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-04 10:33 UTC by Vitor Fernandes
Modified: 2014-08-04 11:23 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vitor Fernandes 2014-08-04 10:33:08 UTC
Currently Koha can only import records from Z39.50.
This feature is to add support to other protocols than Z39.50 when importing records.
Comment 1 Katrin Fischer 2014-08-04 11:00:46 UTC
Vitor, can you be a bit more specific about the protocols you are thinking about? There is already work done on SRU: Bug 6536.
Comment 2 Vitor Fernandes 2014-08-04 11:17:38 UTC
This was an idea from some client that will allow to search/import records from different databases. SRU is a nice improvement, so this bug can also be mark as duplicate. It will suport SRW/SRU?
Comment 3 Katrin Fischer 2014-08-04 11:21:16 UTC
I think it will allow the same workflow that we have now for Z39.50 - downloading the records into Koha and save as new or overwrite an existing record. But I think detail questions would be better on bug 6536.
Comment 4 Vitor Fernandes 2014-08-04 11:23:58 UTC

*** This bug has been marked as a duplicate of bug 6536 ***