Bug 12841 - aqorders fields should not be mapped
Summary: aqorders fields should not be mapped
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 12826
  Show dependency treegraph
 
Reported: 2014-08-28 10:50 UTC by Jonathan Druart
Modified: 2016-06-21 21:37 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 12841: aqorders fields should not be mapped (1.92 KB, patch)
2014-08-28 10:52 UTC, Jonathan Druart
Details | Diff | Splinter Review
sign-off for patch (1.97 KB, patch)
2014-09-13 10:13 UTC, Zeno Tajoli
Details | Diff | Splinter Review
[SIGN_OFF] Aqorders fields should not be mapped (1.98 KB, patch)
2014-09-13 13:00 UTC, Zeno Tajoli
Details | Diff | Splinter Review
[PASSED QA] Bug 12841: aqorders fields should not be mapped (2.05 KB, patch)
2014-09-19 12:36 UTC, Kyle M Hall
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2014-08-28 10:50:24 UTC
Bug 5336 introduced some code which should have been introduced by bug 7294.
Since the idea behind bug 7294 has been abandoned (map the aqorders fields), the code can be removed.
Comment 1 Jonathan Druart 2014-08-28 10:52:58 UTC Comment hidden (obsolete)
Comment 2 Zeno Tajoli 2014-09-13 10:13:08 UTC Comment hidden (obsolete)
Comment 3 Zeno Tajoli 2014-09-13 13:00:10 UTC Comment hidden (obsolete)
Comment 4 Kyle M Hall 2014-09-19 12:36:01 UTC
Created attachment 31737 [details] [review]
[PASSED QA] Bug 12841: aqorders fields should not be mapped

Bug 5336 introduced some code which should have been introduced by bug
7294.
Since the idea behind bug 7294 has been abandoned (map the aqorders
fields), the code can be removed.

Test plan:
Verify that Koha does not allow you to map the aqorders fields with a
MARC subfield.
Verify there is no regression on adding/updating an order.

Signed-off-by: Zeno Tajoli <z.tajoli@cineca.it>

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 5 Tomás Cohen Arazi 2014-12-03 14:53:40 UTC
Patch pushed to master.

Thanks Jonathan!
Comment 6 Chris Cormack 2014-12-03 19:59:21 UTC
Pushed to 3.18.x will be in 3.18.01