Bug 13020 - Checkouts table default ordering is incorrect
Summary: Checkouts table default ordering is incorrect
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low normal (vote)
Assignee: Kyle M Hall
QA Contact: Testopia
URL:
Keywords:
: 13067 (view as bug list)
Depends on: 12550
Blocks:
  Show dependency treegraph
 
Reported: 2014-10-01 13:02 UTC by Kyle M Hall
Modified: 2015-12-03 22:11 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 13020 - Checkouts table default ordering is incorrect (2.49 KB, patch)
2014-10-01 13:04 UTC, Kyle M Hall
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 13020 - Checkouts table default ordering is incorrect (2.59 KB, patch)
2014-10-09 18:00 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 13020 - Checkouts table default ordering is incorrect (2.74 KB, patch)
2014-10-11 15:50 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Kyle M Hall 2014-10-01 13:02:26 UTC
The checkouts table is no longer keeping "today's checkouts" in the order they were scanned.
Comment 1 Kyle M Hall 2014-10-01 13:04:47 UTC Comment hidden (obsolete)
Comment 2 Nick Clemens 2014-10-06 18:15:07 UTC
I am not seeing a difference after applying the patches, in both instances I see the list from top to bottom as 3,1,2

What are the orders for the incorrect function and the desired function?
Comment 3 Owen Leonard 2014-10-09 18:00:35 UTC Comment hidden (obsolete)
Comment 4 Owen Leonard 2014-10-10 14:36:55 UTC
*** Bug 13067 has been marked as a duplicate of this bug. ***
Comment 5 Jonathan Druart 2014-10-11 15:50:18 UTC
Created attachment 32254 [details] [review]
Bug 13020 - Checkouts table default ordering is incorrect

The checkouts table is no longer keeping "today's checkouts" in the
order they were scanned.

Test Plan:
1) Create 3 records "Test 1", "Test 2" and "Test 3" each with one item
2) Check out the items to a patron in the order "Test 2", "Test 1", "Test 3".
3) Note the order is incorrect.
4) Apply this patch
5) Refresh the page
6) Note the order is now correct

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com>
Note that the bug already exists before bug 12550. I checked on a 3.14.x
branch (without the ajax circ stuff), and the order is the same as with
this patch.
Comment 6 Tomás Cohen Arazi 2014-10-19 14:44:34 UTC
Patch pushed to master.

Thanks Kyle!
Comment 7 Mason James 2015-01-22 12:53:03 UTC
Pushed to 3.16.x, patch will be in 3.16.7