Bug 13239 - MySQL Character encoding utf8
Summary: MySQL Character encoding utf8
Status: RESOLVED DUPLICATE of bug 18336
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Galen Charlton
QA Contact: Testopia
URL:
Keywords:
Depends on: 11944 13596
Blocks:
  Show dependency treegraph
 
Reported: 2014-11-12 09:00 UTC by Martin Renvoize
Modified: 2018-05-16 02:39 UTC (History)
15 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Renvoize 2014-11-12 09:00:09 UTC
As discussed in bug 11944 we should use utf8_mb4 as default mysql encoding where the mysql version allows for it.  This would allow for the entire utf8 character range rather than an arbitrarily truncated set as chosen by mysql during their first attempt at utf8 compatibility.

As promised, I've opened this followup bug to track this issue.
Comment 1 Katrin Fischer 2014-11-16 10:33:59 UTC
Hi Martin, I am not sure how this blocks the bugs you listed, can you explain?
Comment 2 Martin Renvoize 2014-11-19 19:26:01 UTC
Back.. Of course it doesn't.. They came in from the clone bug. Oops
Comment 3 Tomás Cohen Arazi 2015-01-21 15:01:15 UTC
Martin, do u plan to provide a patch for this one?
Comment 4 Katrin Fischer 2018-05-16 02:39:53 UTC

*** This bug has been marked as a duplicate of bug 18336 ***