Bug 13253 - Unnecessary white space above checkouts table in circulation
Summary: Unnecessary white space above checkouts table in circulation
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P5 - low minor (vote)
Assignee: Owen Leonard
QA Contact: Testopia
URL:
Keywords:
Depends on: 11703
Blocks:
  Show dependency treegraph
 
Reported: 2014-11-14 01:14 UTC by Owen Leonard
Modified: 2016-12-05 21:23 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 13253 - Unnecessary white space above checkouts table in circulation (2.71 KB, patch)
2014-11-14 01:51 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 13253 - Unnecessary white space above checkouts table in circulation (2.79 KB, patch)
2014-11-14 02:55 UTC, Liz Rea
Details | Diff | Splinter Review
[PASSED QA] Bug 13253 - Unnecessary white space above checkouts table in circulation (2.89 KB, patch)
2014-11-14 05:35 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2014-11-14 01:14:11 UTC
The DataTables sDom configuration for the new AJAX circulation checkouts table contains some superfluous markup which pushes the checkouts table down. This distance can mean the difference, on some screens, between being able to see the last item checked out or not.
Comment 1 Owen Leonard 2014-11-14 01:51:28 UTC Comment hidden (obsolete)
Comment 2 Liz Rea 2014-11-14 02:55:30 UTC Comment hidden (obsolete)
Comment 3 Katrin Fischer 2014-11-14 05:35:54 UTC
Created attachment 33545 [details] [review]
[PASSED QA] Bug 13253 - Unnecessary white space above checkouts table in circulation

On the new checkouts page there is some padding above the checkouts,
relatives' checkouts, and holds tables caused by extra markup in the
table's sDom configuration (http://legacy.datatables.net/ref#sDom):

<'row-fluid'<'span6'><'span6'>r>t<'row-fluid'>t

This creates several empty <div>s which don't serve any purpose. This
patch simplifies it to:

rt

To test, apply the patch, clear your browser cache, and check out to a
patron who has items checked out, holds on their account, and child
records attached which also have checkouts.

The padding above the table of checkouts, the table of relatives'
checkouts, and the table of holds should match that on the sides.

Signed-off-by: Liz Rea <liz@catalyst.net.nz>
Checked per plan on both Check Out and Details pages, spacing appears correct.

Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Works as described, no problems found.
Comment 4 Tomás Cohen Arazi 2014-11-14 12:36:37 UTC
Patch pushed to master.

Thanks Owen!
Comment 5 Mason James 2015-01-20 15:02:30 UTC
Pushed to 3.16.x, patch will be in 3.16.7