Bug 13293 - Regression: Override renewal limit option broken with AJAX circ
Summary: Regression: Override renewal limit option broken with AJAX circ
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P5 - low critical (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Keywords:
Depends on: 11703
Blocks:
  Show dependency treegraph
 
Reported: 2014-11-18 19:54 UTC by Owen Leonard
Modified: 2019-06-27 09:24 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 13293 - Regression: Override renewal limit option broken with AJAX circ (2.16 KB, patch)
2014-11-19 11:32 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 13293 - Regression: Override renewal limit option broken with AJAX circ (3.96 KB, patch)
2014-11-21 14:14 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 13293 - Regression: Override renewal limit option broken with AJAX circ (4.05 KB, patch)
2014-11-22 07:56 UTC, Frédéric Demians
Details | Diff | Splinter Review
[PASSED QA] Bug 13293 - Regression: Override renewal limit option broken with AJAX circ (4.21 KB, patch)
2014-11-22 09:46 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2014-11-18 19:54:57 UTC
The "Override renewal limit" checkbox no longer works to un-hide the renewal checkboxes in the table of checkouts. I assume this is because the script works in such a way that it is looking for the checkboxes before they are part of the document.
Comment 1 Christopher Brannon 2014-11-18 20:36:27 UTC
Should be easy enough to work around.  We found a way to get at stuff on the check out table with jQuery.
Comment 2 Kyle M Hall 2014-11-19 11:32:42 UTC Comment hidden (obsolete)
Comment 3 Owen Leonard 2014-11-19 13:59:14 UTC
Please check the behavior in 3.14.x. The purpose of the "Override renewal limit" option to allow the librarian (if AllowRenewalLimitOverride is enabled) to renew items even after the patron has exceeded the renewal limit. With this patch I can see the checkboxes, but I can't select them because they are disabled.
Comment 4 Katrin Fischer 2014-11-19 20:15:11 UTC
This is a major problem - please fix with high priority.
Comment 5 Kyle M Hall 2014-11-21 14:14:18 UTC Comment hidden (obsolete)
Comment 6 Frédéric Demians 2014-11-22 07:56:35 UTC Comment hidden (obsolete)
Comment 7 Katrin Fischer 2014-11-22 09:46:20 UTC
Created attachment 33805 [details] [review]
[PASSED QA] Bug 13293 - Regression: Override renewal limit option broken with AJAX circ

The "Override renewal limit" checkbox no longer works to un-hide the
renewal checkboxes in the table of checkouts. I assume this is because
the script works in such a way that it is looking for the checkboxes
before they are part of the document.

Test Plan:
1) Apply this patch
2) Check the "Override renewal limit" checkbox
3) Note the checkbox now appears

Note, this change allows the "X of Y renewals remaining" to be displayed
for non-renewable items. I left this as it is for two reasons: 1) it
gives the librarian more information that may be useful, and 2) it looks
nicer and more uniform.

Signed-off-by: Frederic Demians <f.demians@tamil.fr>

I confirm the bug and the solution.

Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Passes tests and QA script, works as described.
Exception: on-site checkouts can't be renewed.
Comment 8 Tomás Cohen Arazi 2014-11-22 14:17:32 UTC
Patch pushed to master.

Thanks Kyle!
Comment 9 Mason James 2015-01-22 16:41:49 UTC
Pushed to 3.16.x, patch will be in 3.16.7