Bug 13296 - error when using z3950 with UNIMARC authorities
Summary: error when using z3950 with UNIMARC authorities
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: master
Hardware: All All
: P5 - low critical (vote)
Assignee: Fridolin SOMERS
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-19 10:55 UTC by Fridolin SOMERS
Modified: 2016-12-05 21:23 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 13296 - error when using z3950 with UNIMARC authorities (3.13 KB, patch)
2014-11-19 11:04 UTC, Fridolin SOMERS
Details | Diff | Splinter Review
Bug 13296 - error when using z3950 with UNIMARC authorities (3.20 KB, patch)
2014-12-10 15:16 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 13296: (follow-up) permit grep on AUTHUNIMARC (1.65 KB, patch)
2014-12-10 15:16 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 13296: (follow-up) permit grep on AUTHUNIMARC (1.65 KB, patch)
2014-12-10 15:20 UTC, Jonathan Druart
Details | Diff | Splinter Review
[PASSED QA] Bug 13296 - error when using z3950 with UNIMARC authorities (3.38 KB, patch)
2014-12-19 12:19 UTC, Katrin Fischer
Details | Diff | Splinter Review
[PASSED QA] Bug 13296: (follow-up) permit grep on AUTHUNIMARC (1.73 KB, patch)
2014-12-19 12:19 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Fridolin SOMERS 2014-11-19 10:55:22 UTC
When using a z3950 connexion with UNIMARC authorities, you get an error : 

Unsupported UNIMARC character encoding [ ] for XML output for UNIMARCAUTH; 100$a -> 20141119 

I've seen thant Bug 2060 when adds authorities import adds a special behavior for UNIMARC : marc flavor must be UNIMARCAUTH instead of just UNIMARC.

The same behavior must exist when using z3950 connexion and import.
Comment 1 Fridolin SOMERS 2014-11-19 11:04:37 UTC Comment hidden (obsolete)
Comment 2 Jonathan Druart 2014-12-10 15:16:43 UTC Comment hidden (obsolete)
Comment 3 Jonathan Druart 2014-12-10 15:16:47 UTC Comment hidden (obsolete)
Comment 4 Jonathan Druart 2014-12-10 15:17:15 UTC
This is critical for UNIMARC users.
Comment 5 Jonathan Druart 2014-12-10 15:20:16 UTC Comment hidden (obsolete)
Comment 6 Katrin Fischer 2014-12-14 19:55:27 UTC
Changes look logical, but I can't get the error to appear on my UNIMARC installation. I tried some UNIMARC targets I found, but none seems to work.
Bit stuck on this - could you share a connection that works for you?
Comment 7 Katrin Fischer 2014-12-18 22:16:20 UTC
This doesn't work for me on current master, I retested, but I only get an empty datatable showing lots of pages. There is lots of noise in the logs, not sure what's wrong. Can you please retest your patch on current master?
Comment 8 Jonathan Druart 2014-12-19 08:46:12 UTC
(In reply to Katrin Fischer from comment #7)
> This doesn't work for me on current master, I retested, but I only get an
> empty datatable showing lots of pages. There is lots of noise in the logs,
> not sure what's wrong. Can you please retest your patch on current master?

Retested right now, the table is correctly filled.
Comment 9 Katrin Fischer 2014-12-19 10:53:19 UTC
Hi Jonathan, I am stuck then with no idea what the problem is :(
Comment 10 Katrin Fischer 2014-12-19 12:12:34 UTC
Jonathan and I figured the problem out - the syntax in the configuration shoudl have been USMARC, while I had chosen UNIMARC. With USMARC it works alright.
Comment 11 Katrin Fischer 2014-12-19 12:19:39 UTC
Created attachment 34531 [details] [review]
[PASSED QA] Bug 13296 - error when using z3950 with UNIMARC authorities

When using a z3950 connexion with UNIMARC authorities, you get an error :
Unsupported UNIMARC character encoding [ ] for XML output for UNIMARCAUTH; 100$a -> 20141119

I've seen thant Bug 2060 when adds authorities import adds a special behavior for UNIMARC : marc flavor must be UNIMARCAUTH instead of just UNIMARC.

This patch adds the same behavior when using z3950 connexion and import.

Test plan :
 - Use a UNIMARC install
 - Define a z3950 connexion for UNIMARC authorities
 - Go to Authorities module
 - Click on "New from Z39.50"
 - Perform a search
=> Without patch : you get the error
=> With patch : you get results
 - Import one result
=> You get the authoritie creation form with all datas
You may check same plan with MARC21 install

Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com>
Signed-off-by: Katrin Fischer <katrin.fischer@bsz-bw.de>
NOTE: depending on the target, the syntax in the configuration
might not be UNIMARC, but MARC21/USMARC instead!
Comment 12 Katrin Fischer 2014-12-19 12:19:53 UTC
Created attachment 34532 [details] [review]
[PASSED QA] Bug 13296: (follow-up) permit grep on AUTHUNIMARC

I would prefer not to hide this "stuff".

Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com>
Signed-off-by: Katrin Fischer <katrin.fischer@bsz-bw.de>
Comment 13 Tomás Cohen Arazi 2014-12-19 18:07:19 UTC
Patches pushed to master.

Thanks Frido!
Comment 14 Chris Cormack 2014-12-19 23:33:39 UTC
Pushed to 3.18.x, will be in 3.18.2
Comment 15 Mason James 2014-12-22 19:01:19 UTC
(In reply to Chris Cormack from comment #14)
> Pushed to 3.18.x, will be in 3.18.2

Pushed to 3.16.x, will be in 3.16.6
Comment 16 Fridolin SOMERS 2014-12-29 17:45:57 UTC
Pushed to 3.14.x, will be in 3.14.13