Bug 13340 - Add a Koha::Config::SystemPreference class for handling sysprefs
Summary: Add a Koha::Config::SystemPreference class for handling sysprefs
Status: RESOLVED DUPLICATE of bug 13967
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Target Milestone: ---
Assignee: Galen Charlton
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-26 04:03 UTC by Tomás Cohen Arazi
Modified: 2015-07-08 17:27 UTC (History)
0 users

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomás Cohen Arazi 2014-11-26 04:03:17 UTC
It needs to:
- be OO
- implement all CRUD operations (create, read, update, delete)
- conveniently log all relevant actions using C4::Log::logaction like this:
  logaction( 'SYSTEMPREFERENCE', 'ADD'...
  logaction( 'SYSTEMPREFERENCE', 'MODIFY'...
  logaction( 'SYSTEMPREFERENCE', 'DELETE'...
- correctly use Koha::Cache

All functions should have
- mocked unit tests
- integration tests, specially thinking of long-living processes (like in Plack).
Comment 1 Tomás Cohen Arazi 2015-07-08 17:27:43 UTC

*** This bug has been marked as a duplicate of bug 13967 ***