Bug 13416 - Typo in marc21_leader.pl position 5 (record status)
Summary: Typo in marc21_leader.pl position 5 (record status)
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: 3.16
Hardware: All All
: P5 - low trivial (vote)
Assignee: Marcel de Rooy
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-09 13:50 UTC by Marcel de Rooy
Modified: 2016-06-21 21:36 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 13416: Typo in marc21_leader.pl position 5 (record status) (1.40 KB, patch)
2014-12-09 13:52 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 13416: Follow-up fix whitespace issues (1.50 KB, patch)
2014-12-16 06:32 UTC, M. Tompsett
Details | Diff | Splinter Review
[SIGNED OFF] Bug 13416: Typo in marc21_leader.pl position 5 (record status) (1.75 KB, patch)
2014-12-16 06:34 UTC, M. Tompsett
Details | Diff | Splinter Review
Bug 13416: Follow-up fix whitespace issues (1.50 KB, patch)
2014-12-16 06:35 UTC, M. Tompsett
Details | Diff | Splinter Review
Bug 13416: Typo in marc21_leader.pl position 5 (record status) (1.81 KB, patch)
2014-12-16 11:59 UTC, Marcel de Rooy
Details | Diff | Splinter Review
[PASSED QA] Bug 13416: Typo in marc21_leader.pl position 5 (record status) (1.87 KB, patch)
2014-12-18 22:36 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Marcel de Rooy 2014-12-09 13:50:16 UTC
Instead of a space in the leader on this position, it should be an a. Trivial fix forthcoming.
Comment 1 Marcel de Rooy 2014-12-09 13:52:39 UTC Comment hidden (obsolete)
Comment 2 M. Tompsett 2014-12-16 06:32:11 UTC Comment hidden (obsolete)
Comment 3 M. Tompsett 2014-12-16 06:34:34 UTC Comment hidden (obsolete)
Comment 4 M. Tompsett 2014-12-16 06:35:13 UTC Comment hidden (obsolete)
Comment 5 Marcel de Rooy 2014-12-16 11:59:33 UTC Comment hidden (obsolete)
Comment 6 Marcel de Rooy 2014-12-16 12:00:49 UTC
Thanks, Mark.
Caused by a tab. When I apply it again, it gets converted into spaces, and the second patch is no longer needed (and not working anymore).
Comment 7 Katrin Fischer 2014-12-18 22:36:57 UTC
Created attachment 34520 [details] [review]
[PASSED QA] Bug 13416: Typo in marc21_leader.pl position 5 (record status)

Instead of a space in the leader on this position, it should be an a.

Test plan:
1) Log in to staff client
2) Find a record in the catalog
3) Edit the record
4) Click the on builder popup icon.
5) View the page source
   -- the option is " " for the 'a- Increase in encoding level'
      entry. It really should be 'a'.
6) Apply patch.
7) Repeat steps 1-5
   -- the option should be 'a' this time.
8) Run koha qa test tools.
   -- Discovered it failed. Provided a patch to fix this.
      It does, however, solve the major problem of ' ' vs. 'a'.

Signed-off-by: Mark Tompsett <mtompset@hotmail.com>
Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Works as described.
Comment 8 Tomás Cohen Arazi 2014-12-19 18:08:18 UTC
Patch pushed to master.

Thanks Marcel!
Comment 9 Chris Cormack 2014-12-19 23:38:37 UTC
String changes, held for 3.18.3
Comment 10 Chris Cormack 2014-12-23 07:24:16 UTC
Pushed to 3.18.x will be in 3.18.3
Comment 11 Mason James 2015-01-16 18:42:38 UTC
Contains string changes, holding for 3.16.8
Comment 12 Mason James 2015-01-18 00:42:30 UTC
Pushed to 3.16.x, will be in 3.16.7