Bug 13440 - 'Check out' tab search for patron gives perl error
Summary: 'Check out' tab search for patron gives perl error
Status: CLOSED WONTFIX
Alias: None
Product: Koha
Classification: Unclassified
Component: Patrons (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low normal (vote)
Target Milestone: ---
Assignee: Bugs List
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-11 13:57 UTC by Katrin Fischer
Modified: 2015-12-03 22:00 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2014-12-11 13:57:07 UTC
To test:
- Log into Koha
- Go to the circulation module
- search for a patron in the database
- perl error is shown :(

Bad arg length for Socket::pack_sockaddr_in, length is 0, should be 4 at /usr/lib/perl5/Socket.pm line 809

This is a 3.18.1 package installation.
Comment 1 Katrin Fischer 2014-12-11 14:09:04 UTC
Hm, I can see this in 2 different installations done from packages, but not in my dev environment, others can't reproduce so far... all ideas welcome.
Comment 2 Katrin Fischer 2014-12-11 14:39:28 UTC
Ok, found the problem, in our koha-conf.xml file, there were some entries causing the problem:

<memcached_servers>__MEMCACHED_SERVERS__</memcached_servers>
<memcached_namespace>__MEMCACHED_NAMESPACE__</memcached_namespace>

Emptying them out fixed the problem:

<memcached_servers></memcached_servers>
<memcached_namespace></memcached_namespace>
Comment 3 Jonathan Druart 2014-12-11 14:40:55 UTC
Maybe should we add a check in the about page?
Comment 4 Katrin Fischer 2014-12-11 14:43:30 UTC
Not sure how common the problem is - I think it happened because we tried to manually complete/change it.
Comment 5 Jonathan Druart 2014-12-11 14:47:32 UTC
It's a bug.
It comes from SQLHelper

koha@koha-qa:~/src (BZ8306↑⚡)% git grep memcache | grep config
C4/SQLHelper.pm:    my $servers = C4::Context->config('memcached_servers');
C4/SQLHelper.pm:            key_prefix  => C4::Context->config('memcached_namespace') || 'koha',
Comment 6 Jonathan Druart 2014-12-11 14:49:00 UTC
Reopened, but not critical now.
Comment 7 Jonathan Druart 2015-04-13 14:31:22 UTC
Bug 11385 will remove this package and should get rid of this bug.