Bug 13470 - pay fines with extended borrower attributes result in application error
Summary: pay fines with extended borrower attributes result in application error
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Patrons (show other bugs)
Version: master
Hardware: All All
: P5 - low critical (vote)
Assignee: Dobrica Pavlinusic
QA Contact: Testopia
URL:
Keywords:
Depends on: 12542
Blocks:
  Show dependency treegraph
 
Reported: 2014-12-16 11:40 UTC by Dobrica Pavlinusic
Modified: 2019-06-27 09:24 UTC (History)
8 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 13470 - pay fines with extended borrower attributes result in application error (1.43 KB, patch)
2014-12-16 11:52 UTC, Dobrica Pavlinusic
Details | Diff | Splinter Review
Bug 13470 - pay fines with extended borrower attributes result in application error (1.48 KB, patch)
2014-12-18 01:15 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Bug 13470 - pay fines with extended borrower attributes result in application error (1.54 KB, patch)
2014-12-19 10:07 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Dobrica Pavlinusic 2014-12-16 11:40:19 UTC
Can't call method "param" on an undefined value at /srv/koha_ffzg/members/paycollect.pl line 182.
Comment 1 Dobrica Pavlinusic 2014-12-16 11:52:43 UTC Comment hidden (obsolete)
Comment 2 Paola Rossi 2014-12-16 15:42:22 UTC
I've tried to create the error case on master 3.19.00.000, but I could not get the error.

I had no error neither using "Pay", nor using "Pay amount" nor using "Pay selected" buttons.

For now I pass the patch to the "In Discussion" status.
Comment 3 Dobrica Pavlinusic 2014-12-17 14:22:20 UTC
I should clarify that this error exists only when running under plack, which makes $template go out of scope since it's not declared with our.
Comment 4 Paola Rossi 2014-12-17 14:49:28 UTC
(In reply to Dobrica Pavlinusic from comment #3)
> I should clarify that this error exists only when running under plack, which
> makes $template go out of scope since it's not declared with our.

Thanks, Dobrica, for your kind explaination.

I'm passing this bug back to "Needs Signoff" status.

But I'm not going to test this bug, because I'd prefer not to install plack.
Comment 5 Aleisha Amohia 2014-12-18 01:15:45 UTC Comment hidden (obsolete)
Comment 6 Jonathan Druart 2014-12-19 10:07:30 UTC
Created attachment 34524 [details] [review]
Bug 13470 - pay fines with extended borrower attributes result in application error

Test scenario:

1. ensure that extended patron attributes are turned on in system preferences
2. find borrower which has fine to pay, and click on pay button
3. verify application error
4. apply patch and verify that application error is gone

Signed-off-by: Aleisha <aleishaamohia@hotmail.com>
Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com>
Comment 7 Jonathan Druart 2014-12-19 10:09:38 UTC
Bug reproduced, I confirm this patch fixes the issue.
No regression found.
Bug introduced by bug 12542.
Note that the pref value is not used by paycollect.tt (which uses circ-menu.tt, not circ-menu.inc). We could remove it, but to be consistent it is better to keep it.
Comment 8 Tomás Cohen Arazi 2014-12-19 18:07:47 UTC
Patch pushed to master.

Thanks Dobrica!
Comment 9 Chris Cormack 2014-12-19 23:36:58 UTC
Pushed to 3.18.x, will be in 3.18.2
Comment 10 Mason James 2014-12-22 19:33:53 UTC
(In reply to Jonathan Druart from comment #7)
> Bug reproduced, I confirm this patch fixes the issue.
> No regression found.
> Bug introduced by bug 12542.

skipping patch for 3.16.x - as bug 12542 is not in 3.16.x branch