Bug 13476 - Item Search feature gets datatables error and doesn't complete search
Summary: Item Search feature gets datatables error and doesn't complete search
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Searching (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on: 11425
Blocks:
  Show dependency treegraph
 
Reported: 2014-12-18 01:44 UTC by Liz Rea
Modified: 2016-06-21 21:36 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 13476: Fix DataTables for the search items form (1.68 KB, patch)
2014-12-19 09:32 UTC, Jonathan Druart
Details | Diff | Splinter Review
[Signed-off] Bug 13476: Fix DataTables for the search items form (1.87 KB, patch)
2014-12-19 16:42 UTC, Marc Véron
Details | Diff | Splinter Review
Bug 13476: Fix DataTables for the search items form (1.91 KB, patch)
2014-12-19 17:56 UTC, Mirko Tietgen
Details | Diff | Splinter Review
Bug 13476: Fix DataTables for the search items form (2.04 KB, patch)
2014-12-19 20:19 UTC, Katrin Fischer
Details | Diff | Splinter Review
paging problem (5.47 KB, image/png)
2014-12-19 20:20 UTC, Katrin Fischer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Liz Rea 2014-12-18 01:44:41 UTC
Attempting to do a search from the new staff client item search screen gives the following error:

DataTables warning: table id=results - Invalid JSON response. For more information about this error, please see http://datatables.net/tn/1
Comment 1 Katrin Fischer 2014-12-18 22:19:42 UTC
I can confirm the bug on 3.18.1, the search is currently not working.
Comment 2 Katrin Fischer 2014-12-18 22:23:06 UTC
Also confirmed on current master.
Comment 3 Jonathan Druart 2014-12-19 09:32:11 UTC Comment hidden (obsolete)
Comment 4 Marc Véron 2014-12-19 16:42:07 UTC Comment hidden (obsolete)
Comment 5 Mirko Tietgen 2014-12-19 17:56:46 UTC Comment hidden (obsolete)
Comment 6 Katrin Fischer 2014-12-19 20:19:20 UTC
Created attachment 34600 [details] [review]
Bug 13476: Fix DataTables for the search items form

This items form is broken since the upgrade to DataTables 1.10.2 (commit
954c2874d0d9ebfa2e910dcd4445010115fac329).
The fnServerParams does not work anymore.

Test plan:
Go on catalogue/itemsearch.pl, launch a search and verify the data are
correctly displayed in the table.

Followed test plan. Works as expected.
Signed-off-by: Marc Véron <veron@veron.ch>

Signed-off-by: Mirko Tietgen <mirko@abunchofthings.net>
Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
The paging seems still a bit buggy, but this makes the
feature usable again!
Comment 7 Katrin Fischer 2014-12-19 20:20:31 UTC
Created attachment 34601 [details]
paging problem
Comment 8 Tomás Cohen Arazi 2014-12-19 20:59:44 UTC
Patch pushed to master.

Thanks Jonathan!
Comment 9 Chris Cormack 2014-12-19 23:51:11 UTC
Pushed to 3.18.x will be in 3.18.2
Comment 10 Jonathan Druart 2014-12-22 10:02:29 UTC
(In reply to Katrin Fischer from comment #7)
> Created attachment 34601 [details]
> paging problem

Fixed by bug 13487.
Comment 11 Mason James 2014-12-22 23:50:50 UTC
(In reply to Chris Cormack from comment #9)
> Pushed to 3.18.x will be in 3.18.2

skipping patch for 3.16.x
Comment 12 Liz Rea 2014-12-23 01:35:26 UTC
Thanks everybody. :)