Bug 13496 - Wrong Koha version on installer title
Summary: Wrong Koha version on installer title
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Tomás Cohen Arazi
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-29 00:02 UTC by Tomás Cohen Arazi
Modified: 2016-06-21 21:37 UTC (History)
1 user (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 13496: add a method for the templates to print Koha version as desired (4.11 KB, patch)
2014-12-29 00:32 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 13496: make auth.tt use a template plugin to get the Koha version (1.64 KB, patch)
2014-12-29 00:33 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 13496: add a method for the templates to print Koha version as desired (4.17 KB, patch)
2015-01-01 06:24 UTC, Chris Cormack
Details | Diff | Splinter Review
Bug 13496: make auth.tt use a template plugin to get the Koha version (1.70 KB, patch)
2015-01-01 06:24 UTC, Chris Cormack
Details | Diff | Splinter Review
[PASSED QA] Bug 13496: add a method for the templates to print Koha version as desired (4.25 KB, patch)
2015-01-02 16:02 UTC, Kyle M Hall
Details | Diff | Splinter Review
[PASSED QA] Bug 13496: make auth.tt use a template plugin to get the Koha version (1.76 KB, patch)
2015-01-02 16:02 UTC, Kyle M Hall
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Tomás Cohen Arazi 2014-12-29 00:02:55 UTC
Steps to reproduce:

- Launch the webinstaller (I deleted my DB to do it)
- The login screen shows
=> FAIL: "Koha 3.0 Installer" is hidden inside the code. It seems to be intended for screen readers to tell it (I cannot test that feature) but I think it is showing the wrong version, and it shouldn't.
Comment 1 Tomás Cohen Arazi 2014-12-29 00:32:02 UTC Comment hidden (obsolete)
Comment 2 Tomás Cohen Arazi 2014-12-29 00:33:41 UTC Comment hidden (obsolete)
Comment 3 Chris Cormack 2015-01-01 06:24:33 UTC Comment hidden (obsolete)
Comment 4 Chris Cormack 2015-01-01 06:24:50 UTC Comment hidden (obsolete)
Comment 5 Kyle M Hall 2015-01-02 16:02:49 UTC
Created attachment 34899 [details] [review]
[PASSED QA] Bug 13496: add a method for the templates to print Koha version as desired

This patch introduces a simple template plugin function that returns
the Koha version number in different suitable formats.

It introduces unit tests for the new function. They are run with

To test:
- Apply the patch
- Run
  $ prove t/Koha_Template_Plugin_Koha.t
=> SUCCESS: the tests pass.
- Sign off :-D

Signed-off-by: Chris Cormack <chris@bigballofwax.co.nz>

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 6 Kyle M Hall 2015-01-02 16:02:55 UTC
Created attachment 34900 [details] [review]
[PASSED QA] Bug 13496: make auth.tt use a template plugin to get the Koha version

This patch makes the installer login template use the new Koha.Version
template plugin to get the correct Koha version. This way we don't need
to maintain the auth.tt file on each version change, and are sure screen
readers tell the correct version.

To test:
- Create a situation where the login screen from the installer shows
- Navigate the HTML code (Ctrl+u)
=> FAIL: "Koha 3.0 Installer" shows on the HTML code
- Apply the patch
- Reload the page
=> SUCCESS: The correct version number is shown.
- Sign off :-D

Signed-off-by: Chris Cormack <chris@bigballofwax.co.nz>

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 7 Tomás Cohen Arazi 2015-01-04 15:22:57 UTC
Patches pushed to master.