Bug 13528 - Ability to search on the different isbn variations
Summary: Ability to search on the different isbn variations
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Searching (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
: 16595 (view as bug list)
Depends on:
Blocks: 17457
  Show dependency treegraph
 
Reported: 2015-01-07 08:46 UTC by Jonathan Druart
Modified: 2017-01-10 06:53 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 13528: Use the different isbn variations on search on the isbn index (nb) (4.87 KB, patch)
2015-01-07 09:57 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 13528: Use the different isbn variations on search on the isbn index (nb) (4.88 KB, patch)
2015-01-15 09:01 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 13528: Use the different isbn variations on search on the isbn index (nb) (4.94 KB, patch)
2015-01-15 20:19 UTC, the.invinnysible.one
Details | Diff | Splinter Review
[PASSED QA] Bug 13528: Use the different isbn variations on search on the isbn index (nb) (4.98 KB, patch)
2015-01-16 17:27 UTC, Kyle M Hall
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2015-01-07 08:46:50 UTC

    
Comment 1 Jonathan Druart 2015-01-07 09:57:23 UTC Comment hidden (obsolete)
Comment 2 the.invinnysible.one 2015-01-15 03:51:03 UTC
I am currently working on this but I am having a conflict with the git commit. It should be able to sign off on this soon.
Comment 3 Jonathan Druart 2015-01-15 09:01:38 UTC Comment hidden (obsolete)
Comment 4 Jonathan Druart 2015-01-15 09:02:26 UTC
(In reply to the.invinnysible.one from comment #2)
> I am currently working on this but I am having a conflict with the git
> commit. It should be able to sign off on this soon.

Thanks!
Note that the correct status is "Does not apply".
Comment 5 the.invinnysible.one 2015-01-15 20:19:20 UTC Comment hidden (obsolete)
Comment 6 the.invinnysible.one 2015-01-15 20:23:02 UTC
Bug 13528 - Ability to search on the different isbn variations

Signed Off
Comment 7 Kyle M Hall 2015-01-16 17:27:59 UTC
Created attachment 35335 [details] [review]
[PASSED QA] Bug 13528: Use the different isbn variations on search on the isbn index (nb)

This enhancement adds the ability to search on all isbn variations when
searching on the isbn index.

Test plan:
0/ Don't apply the patch
1/ Create or choose a notice with an isbn with dashes.
2/ Try to search the notice using the isbn index by it isbn without
dashes.
=> It does not work.
3/ Apply the patch, enable the new pref SearchWithISBNVariations and
disable UseQueryParser.
4/ repeat 2 and note that the record is now returned.

Note that this only works if UseQueryParser is disabled.
It looks like QueryParser does not manage more than 1 operator.
See:
  QueryParser does not manage more than 1 operator?
  http://lists.koha-community.org/pipermail/koha-devel/2014-December/041028.html
and
  commit 036f2a50e11dab97ef8509f2f585c4cc407ea728
  Author: Galen Charlton <gmc@esilibrary.com>
  Date:   Mon May 5 19:31:00 2014 +0000
      Bug 10500: (follow-up) disable AggressiveMatchOnISBN if
      UseQueryParser is on

Signed-off-by: Morag Hills <the.invinnysible.one@gmail.com>

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 8 Tomás Cohen Arazi 2015-04-16 17:23:15 UTC
Enhancement pushed.

Thanks Jonathan!
Comment 9 Marjorie Barry-Vila 2015-11-25 20:32:04 UTC
(In reply to Kyle M Hall from comment #7)
> Created attachment 35335 [details] [review] [review]
> [PASSED QA] Bug 13528: Use the different isbn variations on search on the
> isbn index (nb)
> 
> This enhancement adds the ability to search on all isbn variations when
> searching on the isbn index.
> 
> Test plan:
> 0/ Don't apply the patch
> 1/ Create or choose a notice with an isbn with dashes.
> 2/ Try to search the notice using the isbn index by it isbn without
> dashes.
> => It does not work.
> 3/ Apply the patch, enable the new pref SearchWithISBNVariations and
> disable UseQueryParser.
> 4/ repeat 2 and note that the record is now returned.
> 
> Note that this only works if UseQueryParser is disabled.
> It looks like QueryParser does not manage more than 1 operator.
> See:
>   QueryParser does not manage more than 1 operator?
>  
> http://lists.koha-community.org/pipermail/koha-devel/2014-December/041028.
> html
> and
>   commit 036f2a50e11dab97ef8509f2f585c4cc407ea728
>   Author: Galen Charlton <gmc@esilibrary.com>
>   Date:   Mon May 5 19:31:00 2014 +0000
>       Bug 10500: (follow-up) disable AggressiveMatchOnISBN if
>       UseQueryParser is on
> 
> Signed-off-by: Morag Hills <the.invinnysible.one@gmail.com>
> 
> Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>

Hi Kyle,

Can you tell me if your improvement also works for research in the acquisition module? acqui/histsearch.pl

Regards,
Marjorie
Comment 10 Katrin Fischer 2016-08-14 14:42:57 UTC
*** Bug 16595 has been marked as a duplicate of this bug. ***