Bug 13554 - Bug 12969 introduces a test case that fails
Summary: Bug 12969 introduces a test case that fails
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on: 12969 13275
Blocks:
  Show dependency treegraph
 
Reported: 2015-01-11 23:21 UTC by Robin Sheat
Modified: 2016-06-21 21:36 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 13554: t/Prices.t shouldn't depend on the DB (1.19 KB, patch)
2015-01-12 08:36 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 13554: t/Prices.t shouldn't depend on the DB (1.30 KB, patch)
2015-01-12 12:32 UTC, Paola Rossi
Details | Diff | Splinter Review
[PASSED QA] Bug 13554: t/Prices.t shouldn't depend on the DB (1.31 KB, patch)
2015-01-16 16:51 UTC, Kyle M Hall
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Robin Sheat 2015-01-11 23:21:10 UTC
DBI connect('dbname=koha;host=localhost;port=3306','kohaadmin',...) failed: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) at /tmp/buildd/koha-3.19~git+20150112121205.483ad2ae/blib/PERL_MODULE_DIR/C4/Context.pm line 785
Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) at /tmp/buildd/koha-3.19~git+20150112121205.483ad2ae/blib/PERL_MODULE_DIR/C4/Context.pm line 785.
Compilation failed in require at /tmp/buildd/koha-3.19~git+20150112121205.483ad2ae/blib/PERL_MODULE_DIR/C4/Letters.pm line 27.
BEGIN failed--compilation aborted at /tmp/buildd/koha-3.19~git+20150112121205.483ad2ae/blib/PERL_MODULE_DIR/C4/Letters.pm line 27.
Compilation failed in require at /tmp/buildd/koha-3.19~git+20150112121205.483ad2ae/blib/PERL_MODULE_DIR/C4/Suggestions.pm line 30.
BEGIN failed--compilation aborted at /tmp/buildd/koha-3.19~git+20150112121205.483ad2ae/blib/PERL_MODULE_DIR/C4/Suggestions.pm line 30.
Compilation failed in require at /tmp/buildd/koha-3.19~git+20150112121205.483ad2ae/blib/PERL_MODULE_DIR/C4/Acquisition.pm line 27.
BEGIN failed--compilation aborted at /tmp/buildd/koha-3.19~git+20150112121205.483ad2ae/blib/PERL_MODULE_DIR/C4/Acquisition.pm line 27.
Compilation failed in require at t/Prices.t line 5.
BEGIN failed--compilation aborted at t/Prices.t line 5.
# Looks like your test exited with 255 before it could output anything.
t/Prices.t ..........................
Comment 1 Jonathan Druart 2015-01-12 08:36:59 UTC Comment hidden (obsolete)
Comment 2 Paola Rossi 2015-01-12 12:32:20 UTC Comment hidden (obsolete)
Comment 3 Kyle M Hall 2015-01-16 16:51:09 UTC
Created attachment 35334 [details] [review]
[PASSED QA] Bug 13554: t/Prices.t shouldn't depend on the DB

To reproduce:
- Stop your MySQL server:
  $ sudo service mysql stop
- Run
  $ prove t/Prices.t
=> FAIL: some tests fail because of mysql stopped

To test (MySQL still stopped)
- Apply the patch
- Run
  $ prove t/Prices.t

Signed-off-by: Paola Rossi <paola.rossi@cineca.it>

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 4 Tomás Cohen Arazi 2015-01-17 13:45:47 UTC
Patch pushed to master.

Thanks JOnathan!