Bug 13605 - _AUTHOR_ not replaced in relatives checkouts
Summary: _AUTHOR_ not replaced in relatives checkouts
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Patrons (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
: 13786 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-01-21 08:44 UTC by Fridolin SOMERS
Modified: 2015-12-03 22:02 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 13605 - _AUTHOR_ not replaced in relatives checkouts (1.29 KB, patch)
2015-01-21 09:40 UTC, Fridolin SOMERS
Details | Diff | Splinter Review
Bug 13605 - _AUTHOR_ not replaced in relatives checkouts (1.35 KB, patch)
2015-02-25 04:40 UTC, Brendan Gallagher
Details | Diff | Splinter Review
[PASSED QA] Bug 13605 - _AUTHOR_ not replaced in relatives checkouts (1.46 KB, patch)
2015-03-03 10:15 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Fridolin SOMERS 2015-01-21 08:44:41 UTC
In members/moremember.pl, in relatives checkouts tab, "by _AUTHOR_" appears before author.
This code sould be replaced in JS.
Comment 1 Fridolin SOMERS 2015-01-21 09:40:13 UTC Comment hidden (obsolete)
Comment 2 Brendan Gallagher 2015-02-25 04:40:59 UTC Comment hidden (obsolete)
Comment 3 Katrin Fischer 2015-03-03 10:15:28 UTC
Created attachment 36377 [details] [review]
[PASSED QA] Bug 13605 - _AUTHOR_ not replaced in relatives checkouts

In members/moremember.pl, in relatives checkouts tab, "by _AUTHOR_" appears before author.
This code sould be replaced in JS.

Test plan :
- Go to a borrower with relative's checkouts
=> without patch : you see "by _AUTHOR_" string before author name
=> with patch : you see "by" string before author name

Signed-off-by: Brendan Gallagher <brendan@bywatersolutions.com>
Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Works as described, fixes the problem.
Comment 4 Katrin Fischer 2015-03-03 22:11:07 UTC
*** Bug 13786 has been marked as a duplicate of this bug. ***
Comment 5 Tomás Cohen Arazi 2015-03-05 15:33:49 UTC
Patch pushed to master.

Thanks Frido!
Comment 6 Chris Cormack 2015-03-12 07:18:58 UTC
Pushed to 3.18.x will be in 3.18.5
Comment 7 Mason James 2015-03-26 02:40:50 UTC
Pushed to 3.16.x, will be in 3.16.9