Bug 13641 - 979 prefixed ISBN-13's crash Koha when attempting to convert to ISBN-10's
Summary: 979 prefixed ISBN-13's crash Koha when attempting to convert to ISBN-10's
Status: RESOLVED DUPLICATE of bug 13167
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Galen Charlton
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-29 20:08 UTC by Kyle M Hall
Modified: 2015-01-29 20:11 UTC (History)
1 user (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kyle M Hall 2015-01-29 20:08:59 UTC
ISBN's with a prefix of 979 ( such as 9799577623170 ) cannot be converted to ISBN-10s ( as per http://www.isbn.org/about_ISBN_standard ).

When Koha tries to convert a 13 with a prefix of 979 to a 10, it gets back nothing, on which it calls as_string(). This is not good.
Comment 1 Kyle M Hall 2015-01-29 20:11:01 UTC

*** This bug has been marked as a duplicate of bug 13167 ***