Bug 13647 - On-site checkouts: Allow library to specifiy due date
Summary: On-site checkouts: Allow library to specifiy due date
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P5 - low trivial (vote)
Assignee: Katrin Fischer
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
: 13558 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-01-30 16:48 UTC by Katrin Fischer
Modified: 2015-12-03 22:11 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 13647: On-site checkouts - Allow library to specify due date (2.84 KB, patch)
2015-03-06 10:00 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 13647: On-site checkouts - Allow library to specify due date (2.91 KB, patch)
2015-03-06 10:16 UTC, Nicole C. Engard
Details | Diff | Splinter Review
Bug 13647: On-site checkouts - Allow library to specify due date (2.97 KB, patch)
2015-03-06 11:17 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 13647: On-site checkouts - Allow library to specify due date (3.04 KB, patch)
2015-03-06 11:18 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 13647: On-site checkouts - Allow library to specify due date (3.10 KB, patch)
2015-03-06 11:27 UTC, Nicole C. Engard
Details | Diff | Splinter Review
Bug 13647: On-site checkouts - Allow library to specify due date (3.16 KB, patch)
2015-03-06 13:06 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2015-01-30 16:48:21 UTC
Sometimes the libraries will keep items ready for a patron to use on-site for a longer time than a day. 

It would be good if the feature allowed the library to optionally specify another due date for on-site checkouts. Currently the due date will always default to the end of the current day.
Comment 1 Katrin Fischer 2015-03-06 08:40:23 UTC
After checking with Jonathan, it would be ok to have the library always select the due date and not force it to the end of the day. I will try to make that happen.
Comment 2 Katrin Fischer 2015-03-06 08:49:32 UTC
*** Bug 13558 has been marked as a duplicate of this bug. ***
Comment 3 Katrin Fischer 2015-03-06 10:00:53 UTC Comment hidden (obsolete)
Comment 4 Nicole C. Engard 2015-03-06 10:16:51 UTC Comment hidden (obsolete)
Comment 5 Jonathan Druart 2015-03-06 10:23:13 UTC
Sorry, I found a bug. If SpecifyDueDate is disabled, the due date should be set to today.
Comment 6 Katrin Fischer 2015-03-06 11:17:10 UTC Comment hidden (obsolete)
Comment 7 Katrin Fischer 2015-03-06 11:18:45 UTC Comment hidden (obsolete)
Comment 8 Katrin Fischer 2015-03-06 11:19:31 UTC
oops, bad reflex :)
Comment 9 Nicole C. Engard 2015-03-06 11:27:35 UTC Comment hidden (obsolete)
Comment 10 Jonathan Druart 2015-03-06 13:06:41 UTC
Created attachment 36701 [details] [review]
Bug 13647: On-site checkouts - Allow library to specify due date

This will remove the restriction that forces the due date for
an on-site checkout to the end of the current day.

It will still suggest the end of the day, but you will be able
to change the date to whatever you want using the datepicker
widget.

To test:

Before applying the patch:
- Turn on OnSiteCheckouts and OnSiteCheckoutsForce
  system preferences
- Check the on-site use checkbox and try to set due date
  manually, it should not be possible
- Check out the item and check the due date is set to the
  end of today
- Put a restriction on your patron account and repeat steps,
  the item checked out should again have a due date at the
  end of the day
> There should be no way to be able to check out an item
  with a 'custom' due date

Apply the patch:
- Repeat steps from above, check out
  - on-site use without a restriction on your account
    - without changing the due date
    - with a due date picked with the datepicker
  - on-site use with a restriction on your account
    ... see above
  - no on-site use but with a specified due date
  - no on-site use, not specifying a due date
- Turn off SpecifyDueDate
  - on-site use with and without restriction should
    set the due date automatically to the end of the date
    now, altering the due date should not be possible.

Signed-off-by: Nicole Engard <nengard@bywatersolutions.com>

Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com>
Comment 11 Tomás Cohen Arazi 2015-03-15 12:14:16 UTC
Patch pushed to master.

Good catch Katrina!
Comment 12 Chris Cormack 2015-03-21 22:02:09 UTC
Pushed to 3.18.x will be in 3.18.5