Bug 13650 - Parenthesis in subject links problematic for search
Summary: Parenthesis in subject links problematic for search
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Searching (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Winona Salesky
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
: 9212 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-02-01 22:00 UTC by Katrin Fischer
Modified: 2017-09-12 13:40 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
[PASSED QA] Bug 13650: Remove parens from links to fix searches (8.37 KB, patch)
2015-02-01 22:14 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2015-02-01 22:00:35 UTC

    
Comment 1 Katrin Fischer 2015-02-01 22:14:36 UTC
Created attachment 35652 [details] [review]
[PASSED QA] Bug 13650: Remove parens from links to fix searches

This patch will resolve the issue of not being able to
search with parens in a subject heading by editing the xslt

To test:

* Apply patch
* Search Koha for a title with ( ) in the subject
* Click the subject
* Results should be returned
* Repeat in OPAC and Staff client

Signed-off-by: Nick <Nick@quechelibrary.org>
Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Comment 2 Katrin Fischer 2015-02-01 22:21:10 UTC
*** Bug 9212 has been marked as a duplicate of this bug. ***
Comment 3 Tomás Cohen Arazi 2015-05-20 14:19:37 UTC
Is this a MARC21-only issue?
Comment 4 Tomás Cohen Arazi 2015-05-20 15:24:53 UTC
Patch pushed to master.

Thanks Winona!