Bug 13672 - OPAC locks up browser when browsing items from series link with NoveList and OpacHighlightedWords
Summary: OPAC locks up browser when browsing items from series link with NoveList and ...
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Kyle M Hall
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-02-05 17:19 UTC by Kyle M Hall
Modified: 2015-12-03 22:11 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 13672 - OPAC locks up browser when browsing items from series link with NoveList and OpacHighlightedWords (1.71 KB, patch)
2015-02-05 17:22 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 13672 - OPAC locks up browser when browsing items from series link with NoveList and OpacHighlightedWords (1.75 KB, patch)
2015-02-05 17:43 UTC, Kyle M Hall
Details | Diff | Splinter Review
[PASSED QA] Bug 13672 - OPAC locks up browser when browsing items from series link with NoveList and OpacHighlightedWords (1.94 KB, patch)
2015-02-08 15:59 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Kyle M Hall 2015-02-05 17:19:28 UTC
I have confirmed this issue reported by one of our partners:

I made a screencast of the problem. We just started a NoveList subscription, I'm not sure if it's our scripts conflicting with theirs. I can replicate the problem in the Los Gatos catalog (they also use NoveList). I tried to replicate on non-NoveList OPACs like NEXpress and Plum Creek but the series searching keeps giving me 404s and empty searches.

Screencast: http://screencast.com/t/TLV0G4xfgPN

To replicate:
Search a title with a series (i.e. The Hunger Games)
Click into the record
Click on the series to search it
Click on a title in the search results
If Firefox doesn't crash, it gives the unresponsive script message (seen in the screencast)

Setting OpacHighlightedWords to Don't Highlight fixes the problem. We may go this route but I wanted to make you aware of the problem.

It appears that an empty string is sneaking into the list of words to highlight and that is causing the browser to freak out.
Comment 1 Kyle M Hall 2015-02-05 17:22:02 UTC Comment hidden (obsolete)
Comment 2 Kyle M Hall 2015-02-05 17:43:09 UTC Comment hidden (obsolete)
Comment 3 Katrin Fischer 2015-02-08 15:59:23 UTC
Created attachment 35729 [details] [review]
[PASSED QA] Bug 13672 - OPAC locks up browser when browsing items from series link with NoveList and OpacHighlightedWords

It appears that an empty string is sneaking into the list of words
to highlight and that is causing the browser to freak out.

Test Plan:
1) Enable NoveList
2) Enable OpacHighlightedItems
3) Search a title with a series (i.e. The Hunger Games)
4) Click into the record
5) Click on the series to search it
6) Click on a title in the search results
7) If Firefox doesn't crash, it gives the unresponsive script message
8) Apply this patch
9) Repeat steps 3-6
10) Browser doesn't freak our

Signed-off-by: Jason Robb <jrobb@sekls.org>
Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
could not confirm the problem, but small change and
highlighting terms on result list and couldn't find any
regressions in highlighting.
Comment 4 Tomás Cohen Arazi 2015-02-17 02:46:10 UTC
Patch pushed to master.

Thanks Kyle!
Comment 5 Jonathan Druart 2015-02-17 08:28:05 UTC
Tomas, Kyle, Do you confirm the problem existed before this patch (I didn't test)?

Because this case should be take into account with another line:

  if ( q_array[x].length > 0 ) {

There have been a lot of other reports for this issue (at least bug 10956, bug 9419 and bug 8646), and this line does not exist at the other places.

That makes me think that this patch was unnecessary.
Comment 6 Chris Cormack 2015-02-22 22:54:12 UTC
Template changes, held for 3.18.5