Bug 13864 - Columns configuration - Late orders
Summary: Columns configuration - Late orders
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on: 10212 13875
Blocks: 13865
  Show dependency treegraph
 
Reported: 2015-03-18 12:20 UTC by Jonathan Druart
Modified: 2016-06-21 21:40 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 13864: Columns configuration - Late orders (3.35 KB, patch)
2015-03-18 12:26 UTC, Jonathan Druart
Details | Diff | Splinter Review
The column selection is not synchroized with it's header if window is resized (26.11 KB, image/png)
2015-03-26 08:37 UTC, Marc Véron
Details
[Signed-off] Bug 13864: Columns configuration - Late orders (3.50 KB, patch)
2015-03-27 09:59 UTC, Marc Véron
Details | Diff | Splinter Review
[PASSED QA] Bug 13864: Columns configuration - Late orders (3.60 KB, patch)
2015-04-06 10:06 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 13864: Fix height for Colvis entries (1.07 KB, patch)
2015-04-07 09:11 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2015-03-18 12:20:51 UTC

    
Comment 1 Jonathan Druart 2015-03-18 12:26:12 UTC Comment hidden (obsolete)
Comment 2 Marcel de Rooy 2015-03-19 13:30:59 UTC
If I save a column (information) on the admin page (when hiding it), the admin page does not show that again. The late orders either.
Seems to be a bug of what has been pushed already.
Since I cannot fail QA on master, I do it here :)
Comment 3 Jonathan Druart 2015-03-19 15:37:45 UTC
(In reply to M. de Rooy from comment #2)
> If I save a column (information) on the admin page (when hiding it), the
> admin page does not show that again. The late orders either.
> Seems to be a bug of what has been pushed already.
> Since I cannot fail QA on master, I do it here :)

Caused by the underscore '_' in the table name, I will open a new bug report.
Comment 4 Jonathan Druart 2015-03-19 15:42:16 UTC
Bugfix submitted on bug 13875.
Comment 5 Marc Véron 2015-03-26 08:37:35 UTC
Created attachment 37258 [details]
The column selection is not synchroized with it's header if window is resized

To reproduce:

Click on 'Show/hide columns'
Column selection with ccheckboxes appears
Select or de-select some columns
Resize window to adapt do new table width
Header 'Show hide columns' moves
Column selection dows mot move with 'Show hide columns' (e.g. will be invisible outside the browser window or will display like on this screenshot).
Comment 6 Jonathan Druart 2015-03-26 14:09:10 UTC
I don't have this problem, the column list sticks to the 'Show/hide' button.
I use Iceweasel 31.4.0
Comment 7 Marc Véron 2015-03-26 15:11:34 UTC
Hi Jonathan,

I can reproduce it with:
Debian:
Iceweasel 24.7.0

Win 8:
Firefox 36.0.4
Chrome 41.0.2272.01
IE 11.0.17

To reproduce:
Click on Show/hide colums. Staff client window turns gray/transparent. Directly go to the right border of the browser window and drag browser window to become smaller.

Result: Button "Show/hide" columns is sticky to the right border of browser window and moves with it (float right), but the list with the checkboxes keeps it's position and disappears at the right outside the browser window (like on the screenshot).

To put them under the button again, click twice on "Show/hide columns".

Ah, if I click somewhere inside the browser window before dragging, the checkboxes are hidden and the window turns white. Maybe the same should happen if the browser window is resized?
Comment 8 Jonathan Druart 2015-03-27 08:42:00 UTC
Ok I think I reproduce it.
I click on the "show/hide", resize the window, and indeed the list is not moving.
But if I click somewhere and click again on the "show/hide" button, the list is at the right place.
IMO it's not a bug at all :)
Anyhow I cannot do anything to fix it.
Comment 9 Marc Véron 2015-03-27 09:59:04 UTC
I agree, the position after resizing is not a bug, it is a cosmetic thing. Will sign off.
Comment 10 Marc Véron 2015-03-27 09:59:40 UTC Comment hidden (obsolete)
Comment 11 Katrin Fischer 2015-04-06 09:19:28 UTC
This works nicely for me, but could we improve display for long column names? The estimated delivery date is not looking nice in the display and I am a bit worried about our very long German terms.
Comment 12 Katrin Fischer 2015-04-06 10:06:20 UTC
Created attachment 37524 [details] [review]
[PASSED QA] Bug 13864: Columns configuration - Late orders

This patch adds the ability to hide columns on the late orders page
(acqui/lateorders.pl).

Test plan:
Go on the late orders page and confirm you are able to hide columns.
You can also play with the columns configuration admin page and confirm
that the behaviors are consistent.

Signed-off-by: Marc Véron <veron@veron.ch>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>

http://bugs.koha-community.org/show_bug.cgi?id=13875
Comment 13 Jonathan Druart 2015-04-07 09:11:03 UTC
Created attachment 37537 [details] [review]
Bug 13864: Fix height for Colvis entries

On the late orders page, the "Show/hide columns" displays the "estimated
delivery date" is a litle bit to long and overflows between 2 lines.

This patch fixes the height to 100%.

Test plan:
Go on the late orders page and confirm the "estimeated delivery date"
entry is correctly displayed.
Comment 14 Jonathan Druart 2015-04-07 09:12:07 UTC
(In reply to Katrin Fischer from comment #11)
> This works nicely for me, but could we improve display for long column
> names? The estimated delivery date is not looking nice in the display and I
> am a bit worried about our very long German terms.

Done in the last patch. Could I get your SO on this one? I would like to avoid create a new bug report for this one line patch.
Comment 15 Tomás Cohen Arazi 2015-04-08 18:00:52 UTC
Patches pushed to master.

Thanks Jonathan!