Bug 13926 - SQLHelper replacement - C4::Members::Search - circulation.pl
Summary: SQLHelper replacement - C4::Members::Search - circulation.pl
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Patrons (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 12633
  Show dependency treegraph
 
Reported: 2015-03-30 10:15 UTC by Jonathan Druart
Modified: 2015-12-03 22:11 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 13926: ake circulation.pl not using C4::Members::Search (8.03 KB, patch)
2015-03-30 10:17 UTC, Jonathan Druart
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 13926: ake circulation.pl not using C4::Members::Search (8.12 KB, patch)
2015-04-08 10:47 UTC, Josef Moravec
Details | Diff | Splinter Review
Bug 13926: Reintroduce the correct variable name in template (1.09 KB, patch)
2015-04-13 13:48 UTC, Jonathan Druart
Details | Diff | Splinter Review
[PASSED QA] Bug 13926: ake circulation.pl not using C4::Members::Search (8.17 KB, patch)
2015-04-13 13:59 UTC, Kyle M Hall
Details | Diff | Splinter Review
[PASSED QA] Bug 13926: Reintroduce the correct variable name in template (1.15 KB, patch)
2015-04-13 13:59 UTC, Kyle M Hall
Details | Diff | Splinter Review
[PASSED QA] Bug 13926: ake circulation.pl not using C4::Members::Search (8.05 KB, patch)
2015-04-13 16:57 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
[PASSED QA] Bug 13926: Reintroduce the correct variable name in template (1.21 KB, patch)
2015-04-13 16:57 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2015-03-30 10:15:08 UTC
circ/circulation.pl currently uses C4::Members::Search.
To get rid of SQLHelper, we should not use this subroutine anymore.
Comment 1 Jonathan Druart 2015-03-30 10:17:47 UTC Comment hidden (obsolete)
Comment 2 Josef Moravec 2015-04-08 10:47:04 UTC Comment hidden (obsolete)
Comment 3 Jonathan Druart 2015-04-13 13:48:07 UTC Comment hidden (obsolete)
Comment 4 Kyle M Hall 2015-04-13 13:59:46 UTC Comment hidden (obsolete)
Comment 5 Kyle M Hall 2015-04-13 13:59:54 UTC Comment hidden (obsolete)
Comment 6 Tomás Cohen Arazi 2015-04-13 16:57:23 UTC
Created attachment 37771 [details] [review]
[PASSED QA] Bug 13926: ake circulation.pl not using C4::Members::Search

This patch uses the same method as bug 13894.

Important note: This will modify the UI.
The patron list will now be displayed in a table (instead of a select).

Test plan:
1/ Search for a patron using the checkout tab
2/ The patron list should appear correctly

Test with different type of search (returns 0, 1, 1+ results).

No behavior changes should be observed.

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
works as expected

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Signed-off-by: Tomas Cohen Arazi <tomascohen@gmail.com>
Comment 7 Tomás Cohen Arazi 2015-04-13 16:57:30 UTC
Created attachment 37772 [details] [review]
[PASSED QA] Bug 13926: Reintroduce the correct variable name in template

It's caused by a mistake in previous patch, introduced by bug 13894 too
late, then fixed by 13936.
After this patch, all will be fine in any case :)

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Signed-off-by: Tomas Cohen Arazi <tomascohen@gmail.com>
Comment 8 Tomás Cohen Arazi 2015-04-13 17:45:09 UTC
Rebased patches pushed to master.

Thanks Jonathan!