Bug 13971 - Adjusted locations in koha-rebuild-zebra for gitified instance
Summary: Adjusted locations in koha-rebuild-zebra for gitified instance
Status: RESOLVED DUPLICATE of bug 16733
Alias: None
Product: Koha
Classification: Unclassified
Component: Packaging (show other bugs)
Version: master
Hardware: All All
: P5 - low minor (vote)
Assignee: Marcel de Rooy
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-04-08 14:27 UTC by Marcel de Rooy
Modified: 2016-06-20 11:44 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 13971: Adjusted locations in koha-rebuild-zebra for gitified instance (2.31 KB, patch)
2015-04-08 14:55 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 13971: Adjusted locations in koha-rebuild-zebra for gitified instance (3.93 KB, patch)
2015-04-09 11:16 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 13971: Adjusted locations in koha-rebuild-zebra for gitified instance (3.94 KB, patch)
2015-06-25 10:42 UTC, Mirko Tietgen
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Marcel de Rooy 2015-04-08 14:27:52 UTC

    
Comment 1 Marcel de Rooy 2015-04-08 14:55:42 UTC Comment hidden (obsolete)
Comment 2 Marcel de Rooy 2015-04-08 14:58:24 UTC
Would be interested in feedback on this idea (including the mentioned follow-ups in the commit message) from Robin for packages or Chris for gitify!
Note that I am just exploring Debian now finally :)
Comment 3 Robin Sheat 2015-04-08 23:08:07 UTC
So, Liz and I were chatting about this just yesterday. What I was thinking was having a library file/function that all the scripts run that exports PERL5LIB into the environment, taking it from, perhaps, koha-conf.xml.

Currently koha-conf.xml doesn't really have a facility for a path for this, but adding one wouldn't be a big deal.

On the other hand, I like better your more general (and easier to work with programmatically) method of having a file, though I'd be not inclined to call it 'gitify' just because it's useful in other situations too, I'm sure (though I don't know what :)

So yeah, like the plan and the approach, just think it should be generalised a bit more using the library stuff we have so it works for other scripts too (_especially_ koha-upgrade-schema.)
Comment 4 Marcel de Rooy 2015-04-09 11:16:52 UTC Comment hidden (obsolete)
Comment 5 Marcel de Rooy 2015-04-09 11:21:06 UTC
(In reply to Robin Sheat from comment #3)
> So, Liz and I were chatting about this just yesterday. What I was thinking
> was having a library file/function that all the scripts run that exports
> PERL5LIB into the environment, taking it from, perhaps, koha-conf.xml.
> 
> Currently koha-conf.xml doesn't really have a facility for a path for this,
> but adding one wouldn't be a big deal.
> 
> On the other hand, I like better your more general (and easier to work with
> programmatically) method of having a file, though I'd be not inclined to
> call it 'gitify' just because it's useful in other situations too, I'm sure
> (though I don't know what :)
> 
> So yeah, like the plan and the approach, just think it should be generalised
> a bit more using the library stuff we have so it works for other scripts too
> (_especially_ koha-upgrade-schema.)

Thanks.
Submitted an adjusted patch for those two actually separate things:
1) get a path from koha-conf with get_perl5lib
2) get gitified status from koha-conf too with is_gitified (no longer a file)

So two new functions in koha-functions. Please look too at the scriptdir lines in koha-rebuild-zebra at the start.
Comment 6 Mirko Tietgen 2015-06-25 10:42:43 UTC Comment hidden (obsolete)
Comment 7 Jonathan Druart 2015-08-27 10:51:09 UTC
Looks good to me.
I would like to get a signoff from Robin or Chris Hall to be more comfortable before passing QA on it.
Is there an easy way to know if an instance has been gitified? It will avoid to manually add a new entry to the koha-conf file.
Comment 8 Marcel de Rooy 2015-10-23 08:25:12 UTC
Moving this one to BLOCKED
May come up with a slightly adjusted approach..
Comment 9 Marcel de Rooy 2016-06-20 11:44:17 UTC

*** This bug has been marked as a duplicate of bug 16733 ***