Bug 14055 - Bug 13979 breaks package upgrades
Summary: Bug 13979 breaks package upgrades
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Packaging (show other bugs)
Version: master
Hardware: All All
: P1 - high critical (vote)
Assignee: Robin Sheat
QA Contact: Testopia
URL:
Whiteboard:
Keywords: rel_3_18_candidate
: 14058 (view as bug list)
Depends on: 14068
Blocks: 13979
  Show dependency treegraph
 
Reported: 2015-04-24 02:39 UTC by Robin Sheat
Modified: 2016-12-05 21:23 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 14055: remove symlink that breaks upgrades (898 bytes, patch)
2015-04-24 03:53 UTC, Robin Sheat
Details | Diff | Splinter Review
[PASSED QA] Bug 14055: remove symlink that breaks upgrades (967 bytes, patch)
2015-04-24 23:11 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Robin Sheat 2015-04-24 02:39:02 UTC
Even though the yui symlink is removed in the build, it doesn't go away on a package upgrade, so the upgrade breaks.
Comment 1 Robin Sheat 2015-04-24 03:53:47 UTC Comment hidden (obsolete)
Comment 2 Robin Sheat 2015-04-24 03:54:56 UTC
This can and should be applied to all releases.
Comment 3 Magnus Enger 2015-04-24 06:18:13 UTC
*** Bug 14058 has been marked as a duplicate of this bug. ***
Comment 4 Tomás Cohen Arazi 2015-04-24 23:11:44 UTC
Created attachment 38504 [details] [review]
[PASSED QA] Bug 14055: remove symlink that breaks upgrades

Old versions of koha-common would put in a symlink to the system YUI
libraries. This causes upgrade problems, so we look out for that and zap
it if it's there.

Signed-off-by: Tomas Cohen Arazi <tomascohen@gmail.com>
Comment 5 Tomás Cohen Arazi 2015-04-24 23:17:33 UTC
Patch pushed to master.

Thanks Robin!
Comment 6 Mason James 2015-05-31 00:40:40 UTC
Pushed to 3.16.x, will be in 3.16.11