Bug 14238 - C4::Matcher is mangling data to match on
Summary: C4::Matcher is mangling data to match on
Status: RESOLVED DUPLICATE of bug 17318
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Galen Charlton
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-20 16:19 UTC by Kyle M Hall
Modified: 2016-09-26 17:32 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 14238 - Unit Test to demonstrate issue (899 bytes, patch)
2015-05-20 16:23 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 14238 - Unit Test to demonstrate issue (954 bytes, patch)
2016-06-27 14:33 UTC, Kyle M Hall
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Kyle M Hall 2015-05-20 16:19:42 UTC
When setting up an OCLC match point ( see bug 6499 ) the match always fails because C4::Matcher::_normalize converts "(OCoLC)20329436" to "OCOLC20329436" for reasons unknown. The _normalize subroutine has zero documentation as to what it is supposed to do or not do.
Comment 1 Kyle M Hall 2015-05-20 16:23:14 UTC Comment hidden (obsolete)
Comment 2 David Cook 2016-02-05 04:44:41 UTC
Hey Kyle, I've had the same issue when doing matching. 

Since it has no documentation, I've left it in Koha, but I've created a "none" or "raw" normalizer which skips C4::Matcher::_normalize, as it was butchering URLs...

You can see the signed off patch at: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15541
Comment 3 Owen Leonard 2016-06-21 16:12:50 UTC
Is this report specific to 3.18.x? If it is valid in master, please mark it as
such.
Comment 4 Kyle M Hall 2016-06-27 14:33:19 UTC
Created attachment 52897 [details] [review]
Bug 14238 - Unit Test to demonstrate issue
Comment 5 David Cook 2016-06-28 04:52:58 UTC
Oh... I should add a unit test for the URL mangling as well...
Comment 6 David Cook 2016-08-01 23:40:02 UTC
Kyle, what do you need to move forward on this one?
Comment 7 Tomás Cohen Arazi 2016-09-22 17:54:57 UTC
Bug 17318 introduces new normalization routines (including the misterious option 'None') which could be considered a solution to this bug, and probably also 15541.

Kyle, Galen, David: would you agree on closing this one as duplicate of bug 17318?
Comment 8 David Cook 2016-09-26 05:11:47 UTC
(In reply to Tomás Cohen Arazi from comment #7)
> Bug 17318 introduces new normalization routines (including the misterious
> option 'None') which could be considered a solution to this bug, and
> probably also 15541.
> 
> Kyle, Galen, David: would you agree on closing this one as duplicate of bug
> 17318?

Yep, so long as there's no normalization happening during the matching, I'm happy :).
Comment 9 Kyle M Hall 2016-09-26 17:17:30 UTC
(In reply to David Cook from comment #8)
> (In reply to Tomás Cohen Arazi from comment #7)
> > Bug 17318 introduces new normalization routines (including the misterious
> > option 'None') which could be considered a solution to this bug, and
> > probably also 15541.
> > 
> > Kyle, Galen, David: would you agree on closing this one as duplicate of bug
> > 17318?
> 
> Yep, so long as there's no normalization happening during the matching, I'm
> happy :).

Also agreed!
Comment 10 Tomás Cohen Arazi 2016-09-26 17:32:23 UTC

*** This bug has been marked as a duplicate of bug 17318 ***