Bug 14302 - Remove GRS1 indexing related code
Summary: Remove GRS1 indexing related code
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Jonathan Druart
QA Contact: Katrin Fischer
URL:
Whiteboard:
Keywords:
: 14289 (view as bug list)
Depends on: 12641
Blocks:
  Show dependency treegraph
 
Reported: 2015-05-31 12:45 UTC by Katrin Fischer
Modified: 2018-09-05 14:39 UTC (History)
8 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Medium patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 14302: Remove GRS1 related files (94.61 KB, patch)
2017-02-20 16:04 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 14302: Remove GRS1 specific code (49.54 KB, patch)
2017-02-20 16:04 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 14302: Remove grs1 records from test data (147.34 KB, patch)
2017-02-20 16:04 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 14302: Remove GRS1 related files (94.70 KB, patch)
2018-02-13 20:01 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 14302: Remove GRS1 specific code (49.09 KB, patch)
2018-02-13 20:01 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 14302: Remove grs1 records from test data (147.35 KB, patch)
2018-02-13 20:01 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 14302: Remove GRS1 related files (94.67 KB, patch)
2018-08-24 18:47 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 14302: Remove GRS1 specific code (49.07 KB, patch)
2018-08-24 18:47 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 14302: Remove grs1 records from test data (147.33 KB, patch)
2018-08-24 18:47 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 14302: (QA follow-up) Remove remaining file (2.33 KB, patch)
2018-08-24 18:47 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 14302: (follow-up) Remove traces in koha-create (9.83 KB, patch)
2018-08-24 18:47 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 14302: (follow-up) Remove traces in C4::Search and C4::Context (1.58 KB, patch)
2018-08-24 18:47 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 14302: Remove GRS1 related files (94.72 KB, patch)
2018-08-27 20:26 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 14302: Remove GRS1 specific code (49.07 KB, patch)
2018-08-27 20:26 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 14302: Remove grs1 records from test data (147.39 KB, patch)
2018-08-27 20:26 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 14302: (QA follow-up) Remove remaining file (2.39 KB, patch)
2018-08-27 20:26 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 14302: (follow-up) Remove traces in koha-create (10.10 KB, patch)
2018-08-27 20:26 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 14302: (follow-up) Remove traces in C4::Search and C4::Context (1.63 KB, patch)
2018-08-27 20:26 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2015-05-31 12:45:27 UTC
In hope this is not a duplicate: creating a general entry point bug for removing the GRS1 indexing related code.
Comment 1 Jonathan Druart 2017-02-20 16:04:33 UTC
Created attachment 60469 [details] [review]
Bug 14302: Remove GRS1 related files
Comment 2 Jonathan Druart 2017-02-20 16:04:45 UTC
Created attachment 60470 [details] [review]
Bug 14302: Remove GRS1 specific code

Remove:
- BIB_INDEX_MODE and AUTH_INDEX_MODE env var
- bib_index_mode and auth_index_mode options from scripts
- Warnings from about page, just kept one if zebra_bib_index_mode or
zebra_auth_index_mode still exist in config and are set to grs1

Test plan:
- Install Koha from src
- Install Koha from pkg
- Read the code, carefully!
Comment 3 Jonathan Druart 2017-02-20 16:04:52 UTC
Created attachment 60471 [details] [review]
Bug 14302: Remove grs1 records from test data
Comment 4 Jonathan Druart 2018-02-13 20:01:06 UTC
Created attachment 71570 [details] [review]
Bug 14302: Remove GRS1 related files
Comment 5 Jonathan Druart 2018-02-13 20:01:13 UTC
Created attachment 71571 [details] [review]
Bug 14302: Remove GRS1 specific code

Remove:
- BIB_INDEX_MODE and AUTH_INDEX_MODE env var
- bib_index_mode and auth_index_mode options from scripts
- Warnings from about page, just kept one if zebra_bib_index_mode or
zebra_auth_index_mode still exist in config and are set to grs1

Test plan:
- Install Koha from src
- Install Koha from pkg
- Read the code, carefully!
Comment 6 Jonathan Druart 2018-02-13 20:01:23 UTC
Created attachment 71572 [details] [review]
Bug 14302: Remove grs1 records from test data
Comment 7 Tomás Cohen Arazi 2018-08-24 18:47:24 UTC
Created attachment 78147 [details] [review]
Bug 14302: Remove GRS1 related files

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>
Comment 8 Tomás Cohen Arazi 2018-08-24 18:47:28 UTC
Created attachment 78148 [details] [review]
Bug 14302: Remove GRS1 specific code

Remove:
- BIB_INDEX_MODE and AUTH_INDEX_MODE env var
- bib_index_mode and auth_index_mode options from scripts
- Warnings from about page, just kept one if zebra_bib_index_mode or
zebra_auth_index_mode still exist in config and are set to grs1

Test plan:
- Install Koha from src
- Install Koha from pkg
- Read the code, carefully!

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>
Rebased
Comment 9 Tomás Cohen Arazi 2018-08-24 18:47:34 UTC
Created attachment 78149 [details] [review]
Bug 14302: Remove grs1 records from test data
Comment 10 Tomás Cohen Arazi 2018-08-24 18:47:39 UTC
Created attachment 78150 [details] [review]
Bug 14302: (QA follow-up) Remove remaining file

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>
Comment 11 Tomás Cohen Arazi 2018-08-24 18:47:43 UTC
Created attachment 78151 [details] [review]
Bug 14302: (follow-up) Remove traces in koha-create

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>
Comment 12 Tomás Cohen Arazi 2018-08-24 18:47:47 UTC
Created attachment 78152 [details] [review]
Bug 14302: (follow-up) Remove traces in C4::Search and C4::Context

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>
Comment 13 Tomás Cohen Arazi 2018-08-27 12:49:45 UTC
*** Bug 14289 has been marked as a duplicate of this bug. ***
Comment 14 Katrin Fischer 2018-08-27 20:26:02 UTC
Created attachment 78199 [details] [review]
Bug 14302: Remove GRS1 related files

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 15 Katrin Fischer 2018-08-27 20:26:07 UTC
Created attachment 78200 [details] [review]
Bug 14302: Remove GRS1 specific code

Remove:
- BIB_INDEX_MODE and AUTH_INDEX_MODE env var
- bib_index_mode and auth_index_mode options from scripts
- Warnings from about page, just kept one if zebra_bib_index_mode or
zebra_auth_index_mode still exist in config and are set to grs1

Test plan:
- Install Koha from src
- Install Koha from pkg
- Read the code, carefully!

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>
Rebased

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 16 Katrin Fischer 2018-08-27 20:26:12 UTC
Created attachment 78201 [details] [review]
Bug 14302: Remove grs1 records from test data

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 17 Katrin Fischer 2018-08-27 20:26:16 UTC
Created attachment 78202 [details] [review]
Bug 14302: (QA follow-up) Remove remaining file

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 18 Katrin Fischer 2018-08-27 20:26:21 UTC
Created attachment 78203 [details] [review]
Bug 14302: (follow-up) Remove traces in koha-create

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 19 Katrin Fischer 2018-08-27 20:26:27 UTC
Created attachment 78204 [details] [review]
Bug 14302: (follow-up) Remove traces in C4::Search and C4::Context

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 20 Nick Clemens 2018-08-31 12:58:34 UTC
Awesome work all!

Pushed to master for 18.11
Comment 21 Martin Renvoize 2018-09-05 14:39:14 UTC
Enhancement, will not be backported to 18.05.x series.