Bug 14325 - Test calls C4::Context::set_userenv
Summary: Test calls C4::Context::set_userenv
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: master
Hardware: All All
: P5 - low minor (vote)
Assignee: M. Tompsett
QA Contact: Marcel de Rooy
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-06-03 19:16 UTC by M. Tompsett
Modified: 2016-12-05 21:23 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 14325: Test calls C4::Context::set_userenv (1.34 KB, patch)
2015-06-03 19:29 UTC, M. Tompsett
Details | Diff | Splinter Review
Bug 14325: Test calls C4::Context::set_userenv (1.42 KB, patch)
2015-06-03 22:42 UTC, Indranil Das Gupta
Details | Diff | Splinter Review
Bug 14325: Test calls C4::Context::set_userenv (1.52 KB, patch)
2015-06-04 07:52 UTC, Marcel de Rooy
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description M. Tompsett 2015-06-03 19:16:24 UTC
Bug 8007 added a C4::Context::set_userenv call, after bug 10900 corrected all instances to C4::Context->set_userenv calls.

This will appropriately patch the test.
Comment 1 M. Tompsett 2015-06-03 19:29:55 UTC Comment hidden (obsolete)
Comment 2 Indranil Das Gupta 2015-06-03 22:42:00 UTC Comment hidden (obsolete)
Comment 3 Marcel de Rooy 2015-06-04 07:52:08 UTC
Created attachment 39833 [details] [review]
Bug 14325: Test calls C4::Context::set_userenv

This is a case of works by accident. This patch corrects the
set_userenv call.

TEST PLAN
---------
1) prove t/db_dependent/Borrower_Discharge.t
   -- works
2) git grep :set_userenv
   -- only this one file.
3) Confirm the the C4/Context.pm has a set_userenv
   which shifts the first parameter, as intended for
   a -> call and not a :: call.
4) apply patch
5) prove t/db_dependent/Borrower_Discharge.t
   -- still works
6) git grep :set_userenv
   -- nothing now.
7) run koha qa test tools

Signed-off-by: Indranil Das Gupta (L2C2 Technologies) <indradg@gmail.com>
Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Comment 4 Tomás Cohen Arazi 2015-06-04 13:17:10 UTC
Patch pushed to master.

Thanks Mark!
Comment 5 Chris Cormack 2015-06-07 07:43:59 UTC
Pushed to 3.20.x will be in 3.20.1