Bug 14373 - Disallow payment of accruing fines
Summary: Disallow payment of accruing fines
Status: RESOLVED DUPLICATE of bug 13044
Alias: None
Product: Koha
Classification: Unclassified
Component: Fines and fees (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Kyle M Hall
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-06-10 12:06 UTC by Kyle M Hall
Modified: 2019-11-21 09:17 UTC (History)
9 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 14373 - Disallow payment of accruing fines (4.70 KB, patch)
2015-06-10 13:12 UTC, Kyle M Hall
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Kyle M Hall 2015-06-10 12:06:24 UTC
Some libraries wish to prevent payment of accruing fines so that when backdating returns it will not create a negative balance for patrons that paid those fines in advance.
Comment 1 Kyle M Hall 2015-06-10 13:12:49 UTC
Created attachment 40064 [details] [review]
Bug 14373 - Disallow payment of accruing fines
Comment 2 Kyle M Hall 2015-06-10 13:13:15 UTC
Test Plan:
1) Apply this patch
2) Note accruing fines don't show up in the pay fines table
3) Note that paying by amount does not pay on accruing fines
Comment 3 j.kylmala 2015-08-20 12:34:09 UTC
I wasn't able to apply the patch because some 3-way merge problems. Can you send the patch again in a version where there is no connections to some other git histories, or what might be causing the problem.
Comment 4 Katrin Fischer 2019-02-04 23:53:06 UTC
Quite sure I saw discussion on this on another bug today, can you help me link? (can't find it)
Comment 5 Martin Renvoize 2019-02-14 13:17:36 UTC
No idea I'm afraid Katrin.. however this patch is old enough now that nearly all the code beneath it has changed so it would need a fairly drastic rebase to work regardless.
Comment 6 Tomás Cohen Arazi 2019-02-14 13:55:28 UTC
Is this still relevant, Kyle?
Comment 7 Joy Nelson 2019-02-14 14:36:46 UTC

*** This bug has been marked as a duplicate of bug 13044 ***