Bug 14398 - Duplicate inventory results when an item is in the wrong place (ie using branch/location filter)
Summary: Duplicate inventory results when an item is in the wrong place (ie using bran...
Status: CLOSED DUPLICATE of bug 14399
Alias: None
Product: Koha
Classification: Unclassified
Component: Tools (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Galen Charlton
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-06-17 05:42 UTC by David Cook
Modified: 2017-03-29 12:51 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Cook 2015-06-17 05:42:55 UTC
At the moment, if an item is in the "wrong place" during an inventory, it will show up with a "problem" of "Item should not have been scanned", which makes sense.

However, a duplicate row will also turn up saying "Change item status". This is a row that comes up due to a bug in the processing of not for loan values http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12913. 

In other words... an item might have multiple problems, but instead of listing multiple problems, an entire extra row gets added to the inventory results.

I suppose this could be by design, but it seems like a bug to me, especially if you're feeding your inventory results into "Batch Item Modify" later...
Comment 1 David Cook 2015-06-17 06:04:14 UTC
It might be worth adding that http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14399 makes it so that you can get triple result rows for a single item...
Comment 2 David Cook 2015-06-17 06:45:34 UTC
I imagine this might take a fair bit of refactoring to get working...
Comment 3 Marcel de Rooy 2017-03-29 12:50:54 UTC
The problem with Change item status-lines is now resolved on bug 12913.
I will address the Item missing-problem on bug 14399.
That makes this bug a duplicate, since we would only keep one line for the wrongly placed item.

*** This bug has been marked as a duplicate of bug 14399 ***