Bug 14443 - Man pages need to be updated for koha-mysql
Summary: Man pages need to be updated for koha-mysql
Status: RESOLVED DUPLICATE of bug 12372
Alias: None
Product: Koha
Classification: Unclassified
Component: Command-line Utilities (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Galen Charlton
QA Contact: Testopia
URL:
Keywords:
Depends on: 12372
Blocks:
  Show dependency treegraph
 
Reported: 2015-06-23 16:35 UTC by Barton Chittenden
Modified: 2015-07-12 21:00 UTC (History)
1 user (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Barton Chittenden 2015-06-23 16:35:05 UTC
The following bug:

Bug 12372 -- "feature request: debian/scripts/koha-mysql should be able to handle arbitrary mysql arguments."

Extends the way that koha-mysql may be called. Once that patch is applied, arbitrary mysql arguments may be given after the instance name.

The synopsis should change to

    koha-mysql INSTANCE-NAME [ mysql arguments ]

Also, the '-e' option is now available, so the example usage may change to

    koha-mysql {instancename} -e "Some SQL query"

It would also be useful to provide an explicit example of a mysql argument whose functionality was previously entirely unavailable, e.g.

    koha-mysql {instancename} --skip-column-names

'See Also' should mention mysql.
Comment 1 Robin Sheat 2015-06-28 23:11:41 UTC
The man page update should really be done on bug 12372, there's not really any point having them separate.
Comment 2 Barton Chittenden 2015-07-12 21:00:09 UTC
Added 'TODO' note to 12372 which covers documentation. Closing this bug as a duplicate.

*** This bug has been marked as a duplicate of bug 12372 ***