Bug 14621 - Messaging preferences table needs to be sorted
Summary: Messaging preferences table needs to be sorted
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Lari Taskula
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 14590
  Show dependency treegraph
 
Reported: 2015-07-30 15:23 UTC by Lari Taskula
Modified: 2017-06-14 22:05 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 14621 - Messaging preferences table needs to be sorted (1.34 KB, patch)
2015-08-14 11:51 UTC, Lari Taskula
Details | Diff | Splinter Review
Bug 14621 - Messaging preferences table needs to be sorted (1.40 KB, patch)
2015-09-03 04:17 UTC, Chris Cormack
Details | Diff | Splinter Review
Bug 14621 - Messaging preferences table needs to be sorted (1.47 KB, patch)
2015-09-03 08:28 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Lari Taskula 2015-07-30 15:23:57 UTC
I have been working with messaging preferences and I noticed a weird issue in Firefox on Ubuntu.

On messaging preferences page, the table is unsorted and the content in rows are generated randomly on every page refresh. When you select/deselect checkboxes and refresh the page (without posting the changes), Firefox will remember your choices. Now the issue is that when the table is unsorted and the rows keep changing on page refresh, Firefox has trouble remembering your choices. This makes it appear as if the checkboxes are magically changing values on each page refresh.

We need to have the items sorted in the table to prevent this from happening.
Comment 1 Lari Taskula 2015-08-14 11:51:03 UTC Comment hidden (obsolete)
Comment 2 Chris Cormack 2015-09-03 04:17:18 UTC Comment hidden (obsolete)
Comment 3 Jonathan Druart 2015-09-03 08:28:41 UTC
Created attachment 42273 [details] [review]
Bug 14621 - Messaging preferences table needs to be sorted

I have been working with messaging preferences and I noticed a weird issue in Firefox on Ubuntu.

On messaging preferences page, the table is unsorted and the content in rows are generated randomly
on every page refresh. When you select/deselect checkboxes and refresh the page (without posting the changes),
Firefox will remember your choices. Now the issue is that when the table is unsorted and the rows keep
changing on page refresh, Firefox has trouble remembering your choices. This makes it appear as if the
checkboxes are magically changing values on each page refresh.

Here is a patch that prevents this problem by sorting the messaging settings.

Signed-off-by: Chris Cormack <chrisc@catalyst.net.nz>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 4 Jonathan Druart 2015-09-03 08:28:53 UTC
Very useful patch, thanks!
Comment 5 Tomás Cohen Arazi 2015-09-07 15:27:02 UTC
Patch pushed to master.

Thanks Lari! And congratulations for your commit!
Comment 6 Chris Cormack 2015-09-22 16:57:19 UTC
Pushed to 3.20.x will be in 3.20.4