Bug 14649 - fund names not displayed in budget planning
Summary: fund names not displayed in budget planning
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on: 11714
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-05 15:06 UTC by Fridolin SOMERS
Modified: 2016-06-21 21:38 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 14649: Fix regression - display fund name on budget planning (2.64 KB, patch)
2015-08-06 06:22 UTC, Jonathan Druart
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 14649: Fix regression - display fund name on budget planning (2.71 KB, patch)
2015-08-06 07:42 UTC, Fridolin SOMERS
Details | Diff | Splinter Review
Bug 14649: Followup - correct budget_period_id in fund name link (2.04 KB, patch)
2015-08-06 07:58 UTC, Fridolin SOMERS
Details | Diff | Splinter Review
Bug 14649: Followup - correct budget_period_id in fund name link (2.05 KB, patch)
2015-08-20 09:07 UTC, Fridolin SOMERS
Details | Diff | Splinter Review
Bug 14649: Fix regression - display fund name on budget planning (2.76 KB, patch)
2015-09-03 07:21 UTC, Chris Cormack
Details | Diff | Splinter Review
Bug 14649: Followup - correct budget_period_id in fund name link (2.10 KB, patch)
2015-09-03 07:21 UTC, Chris Cormack
Details | Diff | Splinter Review
[PASSED QA] Bug 14649: Followup - correct budget_period_id in fund name link (2.17 KB, patch)
2015-09-03 22:33 UTC, Katrin Fischer
Details | Diff | Splinter Review
[PASSED QA] Bug 14649: Fix regression - display fund name on budget planning (2.83 KB, patch)
2015-09-03 22:34 UTC, Katrin Fischer
Details | Diff | Splinter Review
[PASSED QA] Bug 14649: Followup - correct budget_period_id in fund name link (2.17 KB, patch)
2015-09-03 22:34 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Fridolin SOMERS 2015-08-05 15:06:27 UTC
In a budget planning, cgi-bin/koha/admin/aqplan.pl, the fund names are not displayed.
Comment 1 Fridolin SOMERS 2015-08-05 15:07:49 UTC
This is a side effect of Bug 11714
Comment 2 Jonathan Druart 2015-08-06 06:22:55 UTC Comment hidden (obsolete)
Comment 3 Fridolin SOMERS 2015-08-06 07:42:34 UTC Comment hidden (obsolete)
Comment 4 Fridolin SOMERS 2015-08-06 07:44:32 UTC
Thanks a lot Jonathan, you where faster than me for patching ;)
I of course signoff.

> Note that this patch impacts the CSV export, which does not work, so it cannot be tested.
I have a correction I will set in another bug.
Comment 5 Fridolin SOMERS 2015-08-06 07:58:15 UTC Comment hidden (obsolete)
Comment 6 Fridolin SOMERS 2015-08-06 07:58:57 UTC
Small followup needs signoff
Comment 7 Mirko Tietgen 2015-08-11 12:25:27 UTC
(In reply to Fridolin SOMERS from comment #5)

> => You see in URL that budget_id is empty :
>    /cgi-bin/koha/admin/aqbudgets.pl?op=add_form&budget_id=6&budget_period_id=

> => you see in URL that budget_id is defined like in planning page :
>    
> /cgi-bin/koha/admin/aqbudgets.pl?op=add_form&budget_id=6&budget_period_id=2

Do you mean »budget_period_id is empty/defined« (not budget_id) in both cases?
Comment 8 Fridolin SOMERS 2015-08-20 09:05:05 UTC
(In reply to Mirko Tietgen from comment #7)
> (In reply to Fridolin SOMERS from comment #5)
> 
> > => You see in URL that budget_id is empty :
> >    /cgi-bin/koha/admin/aqbudgets.pl?op=add_form&budget_id=6&budget_period_id=
> 
> > => you see in URL that budget_id is defined like in planning page :
> >    
> > /cgi-bin/koha/admin/aqbudgets.pl?op=add_form&budget_id=6&budget_period_id=2
> 
> Do you mean »budget_period_id is empty/defined« (not budget_id) in both
> cases?

Yes indeed, thanks for this
Comment 9 Fridolin SOMERS 2015-08-20 09:07:31 UTC Comment hidden (obsolete)
Comment 10 Chris Cormack 2015-09-03 07:21:23 UTC Comment hidden (obsolete)
Comment 11 Chris Cormack 2015-09-03 07:21:42 UTC Comment hidden (obsolete)
Comment 12 Katrin Fischer 2015-09-03 22:33:41 UTC Comment hidden (obsolete)
Comment 13 Katrin Fischer 2015-09-03 22:34:10 UTC
Created attachment 42368 [details] [review]
[PASSED QA] Bug 14649: Fix regression - display fund name on budget planning

A patch from bug 11714 removes 'budget_name_indent', which was useless.
The script and the template should use the budget_name value.

Note that this patch impacts the CSV export, which does not work, so it cannot be
tested.

Test plan:
Edit a fund and click on one of the Planning value (by months, etc.)
The "Fund name" column should be correctly populated with the fund
names.

Signed-off-by: Fridolin Somers <fridolin.somers@biblibre.com>
Signed-off-by: Chris Cormack <chrisc@catalyst.net.nz>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 14 Katrin Fischer 2015-09-03 22:34:44 UTC
Created attachment 42369 [details] [review]
[PASSED QA] Bug 14649: Followup - correct budget_period_id in fund name link

Now that fund name is displayed in the table as a link, you see that arg budget_period_id is never defined in this link.

This is because the template var is [% budget_line.budget_period_id %] instead of [% budget_period_id %].
This looks like a mistake when converting from tmpl to tt.

Test plan :
- Without patch
- Look for a planning with funds :
    /cgi-bin/koha/admin/aqplan.pl?budget_period_id=2&authcat=MONTHS
- Click on a fund name
=> You see in URL that budget_period_id is empty :
    /cgi-bin/koha/admin/aqbudgets.pl?op=add_form&budget_id=6&budget_period_id=
- Apply patch
- Look for a planning with funds :
    /cgi-bin/koha/admin/aqplan.pl?budget_period_id=2&authcat=MONTHS
- Click on a fund name
=> you see in URL that budget_period_id is defined like in planning page :
    /cgi-bin/koha/admin/aqbudgets.pl?op=add_form&budget_id=6&budget_period_id=2

Signed-off-by: Chris Cormack <chrisc@catalyst.net.nz>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 15 Tomás Cohen Arazi 2015-09-07 14:59:29 UTC
Patches pushed to master.

Good catch Jonathan and Frido!
Comment 16 Chris Cormack 2015-09-22 02:06:58 UTC
Pushed to 3.20.x will be in 3.20.4