Bug 14667 - Label creator UI/UX revamp
Summary: Label creator UI/UX revamp
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Label/patron card printing (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Liz Rea
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 14718 15072
  Show dependency treegraph
 
Reported: 2015-08-10 09:30 UTC by Liz Rea
Modified: 2016-06-21 21:40 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 14667 - UI/UX improvements for the Label creator (26.14 KB, patch)
2015-08-10 10:24 UTC, Liz Rea
Details | Diff | Splinter Review
[Signed off] Bug 14667 - UI/UX improvements for the Label creator (26.32 KB, patch)
2015-08-12 19:32 UTC, Chris Nighswonger
Details | Diff | Splinter Review
Bug 14667 - UI/UX improvements for the Label creator (26.38 KB, patch)
2015-08-18 16:41 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 14667: Make some strings translatable (7.19 KB, patch)
2015-08-18 16:41 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 14667: (QA followup) make the UI show 'Label creator' consistently (5.84 KB, patch)
2015-10-06 14:39 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 14667: (QA followup) make the UI show 'Label creator' consistently (8.99 KB, patch)
2015-10-06 15:55 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 14667: (QA followup) remove useless labels-menu.inc file (4.76 KB, patch)
2015-10-06 15:56 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Liz Rea 2015-08-10 09:30:18 UTC
The label creator is overdue for some UI/UX attention. This bug will keep track of the proposed changes.
Comment 1 Liz Rea 2015-08-10 10:24:30 UTC Comment hidden (obsolete)
Comment 2 Chris Nighswonger 2015-08-12 19:04:44 UTC
Nice improvements, Liz. I'd like to see these applied to the patron card tool in conjunction with this to keep the interfaces similar in look and feel.
Comment 3 Chris Nighswonger 2015-08-12 19:32:13 UTC Comment hidden (obsolete)
Comment 4 Liz Rea 2015-08-12 22:35:16 UTC
Hi Chris,

That is a good point, I'll put it on my list of pet projects, because yeah, that part needs updating too. There are lots of places that need love. :)

I wonder, could you help out with one thing though - the table headers are untranslatable at the moment, if you have some time could you have a look at that, or give me some hints as to how that could be done in a translatable way?

Liz
Comment 5 HB-NEKLS 2015-08-12 22:45:25 UTC
I'll be taking a look at this -- because this area definitely needed some love. And +1 on overhauling the patron card creator, including taking on bug 12804, please! 

Looking forward to looking at it, Liz.
Comment 6 Chris Nighswonger 2015-08-13 13:11:43 UTC
(In reply to Liz Rea from comment #4)
> Hi Chris,
> 
> That is a good point, I'll put it on my list of pet projects, because yeah,
> that part needs updating too. There are lots of places that need love. :)

And don't forget manual re-writes to match the new interface... ;-)

> 
> I wonder, could you help out with one thing though - the table headers are
> untranslatable at the moment, if you have some time could you have a look at
> that, or give me some hints as to how that could be done in a translatable
> way?

I implemented DT in both of these sections before (IIRC) it was implemented in Koha generally. I'm not sure what mechanism is currently used, but probably the code would need to be refactored to match what's presently being done other places. I'm pretty much unfamiliar with how that is, so I'll not be much help there.
Comment 7 Jonathan Druart 2015-08-18 16:41:38 UTC
Created attachment 41625 [details] [review]
Bug 14667 - UI/UX improvements for the Label creator

Signed-off-by: Chris Nighswonger <cnighswonger@foundations.edu>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 8 Jonathan Druart 2015-08-18 16:41:44 UTC
Created attachment 41626 [details] [review]
Bug 14667: Make some strings translatable

This patch 1/ Fixes a regression introduced by the previous patch: the
"Are you sure to delete..." strings was translatable and 2/ Make the
table headers translatable.

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 9 Jonathan Druart 2015-08-18 16:43:23 UTC
Liz, don't you think the help on the label home page was helpful ("Welcome to Koha's label creator module")?
Comment 10 Liz Rea 2015-08-18 21:12:16 UTC
I didn't - the reason I didn't is because it is not like any other page. That help should be in the upper right hand help menu, in my opinion.

Also thank you very much for helping out with the translation stuff. :)

Cheers,
Liz
Comment 11 Chris Nighswonger 2015-08-18 22:12:43 UTC
On the other hand, I thought it was cool and that every tool should have a solid intro page which gives a brief overview of its purpose and usage. But that's just my opinion. And pretty biased at that since I created it. ;-)
Comment 12 Liz Rea 2015-08-18 22:28:37 UTC
:) I can totally understand where you're coming from there.

I have observed, when watching librarians learn this tool, that they just don't read it, and the wall of text distracts them from what they are supposed to do. Possibly though, that's because I emphasize the help in the upper right hand corner so they get it drilled into them to look there for help.

Certainly the decision to remove it isn't scientific by any stretch, just based on my observations of people using the tool. :)
Comment 13 Tomás Cohen Arazi 2015-10-06 14:39:45 UTC Comment hidden (obsolete)
Comment 14 Tomás Cohen Arazi 2015-10-06 15:55:51 UTC
Created attachment 43176 [details] [review]
Bug 14667: (QA followup) make the UI show 'Label creator' consistently

The tool is documented and accessed (via Tools >) as 'Label creator'. But the
pages titles say 'Labels' and the breadcumbs 'Labels home'. It should be called
'Label creator' for consistency. This patch changes the tt files so they are
consistent.

It also makes the title show the same page name as the breadcumbs.

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>
Comment 15 Tomás Cohen Arazi 2015-10-06 15:56:02 UTC
Created attachment 43177 [details] [review]
Bug 14667: (QA followup) remove useless labels-menu.inc file

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>
Comment 16 Tomás Cohen Arazi 2015-10-06 16:20:46 UTC
Patches pushed to master.

Good job Liz!
Comment 17 Liz Rea 2015-10-06 20:21:39 UTC
Oh awesome,thanks for the followups!