Bug 14685 - Cannot set guarantor for a child account
Summary: Cannot set guarantor for a child account
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P5 - low critical (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
: 14688 (view as bug list)
Depends on: 13970
Blocks: 17766
  Show dependency treegraph
 
Reported: 2015-08-17 04:27 UTC by Liz Rea
Modified: 2017-01-25 00:41 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 14685: Fix set guarantor for a child account (1.27 KB, patch)
2015-08-17 12:24 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 14685: Fix set guarantor for a child account (1.43 KB, patch)
2015-08-17 21:17 UTC, Liz Rea
Details | Diff | Splinter Review
Bug 14685: Fix set guarantor for a child or professional accounts (1.54 KB, patch)
2015-08-18 08:10 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 14685: Fix set guarantor for a child or professional accounts (1.64 KB, patch)
2015-08-18 21:18 UTC, Liz Rea
Details | Diff | Splinter Review
[PASSED QA] Bug 14685: Fix set guarantor for a child or professional accounts (1.70 KB, patch)
2015-09-01 21:30 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Liz Rea 2015-08-17 04:27:57 UTC
In 3.20.2 one cannot add a child and set the guarantor. It appears this was introduced by bug 13970.
Comment 1 Jonathan Druart 2015-08-17 12:24:36 UTC Comment hidden (obsolete)
Comment 2 Liz Rea 2015-08-17 21:17:00 UTC Comment hidden (obsolete)
Comment 3 Jonathan Druart 2015-08-18 08:10:31 UTC Comment hidden (obsolete)
Comment 4 Jonathan Druart 2015-08-18 08:10:51 UTC
*** Bug 14688 has been marked as a duplicate of this bug. ***
Comment 5 Jonathan Druart 2015-08-18 08:11:57 UTC
Liz, thanks for testing!
I have marked bug 14688 as duplicate, the patch should fix the 2 regressions (more?) introduced by bug 13970.
Comment 6 Liz Rea 2015-08-18 21:18:02 UTC Comment hidden (obsolete)
Comment 7 Katrin Fischer 2015-09-01 21:29:26 UTC
One small thing - I think the pop up window is not wide enough now. It forces you to make it bigger to be able to actually add the patron. Would be good to adjust that as a follow up.
Comment 8 Katrin Fischer 2015-09-01 21:29:35 UTC
... or separately :)
Comment 9 Katrin Fischer 2015-09-01 21:30:05 UTC
Created attachment 42180 [details] [review]
[PASSED QA] Bug 14685: Fix set guarantor for a child or professional accounts

Bug 13970 removed some useful code to automatically set the guarantor
when creating a child.

But finally there is a better way to do the job, we just need to assume
that only children or professional can have a guarantor.

Test plan:
1/ Create an adult patron and add a child.
2/ The guarantor info should be retrieved and set on the child creation
page.
3/ Create an organization and add a child
4/ The guarantor info should be retrieved and set on the adult creation
page.

Signed-off-by: Liz Rea <liz@catalyst.net.nz>
This patch catches both cases, thanks Jonathan!

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 10 Tomás Cohen Arazi 2015-09-02 14:08:31 UTC
Patch pushed to master.

Thanks Jonathan!
Comment 11 Chris Cormack 2015-09-22 01:19:57 UTC
Pushed to 3.20.x will be in 3.20.4