Bug 14696 - useless use of String::Random in catalogue/search.pl
Summary: useless use of String::Random in catalogue/search.pl
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: master
Hardware: All All
: P5 - low minor (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-08-19 15:22 UTC by Jonathan Druart
Modified: 2016-06-21 21:40 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 14696: useless use of String::Random in catalogue/search.pl (874 bytes, patch)
2015-08-19 15:25 UTC, Jonathan Druart
Details | Diff | Splinter Review
Looks like there is no dependencies to that module. (1019 bytes, patch)
2015-08-20 08:10 UTC, j.kylmala
Details | Diff | Splinter Review
[PASSED QA] Bug 14696: useless use of String::Random in catalogue/search.pl (1.06 KB, patch)
2015-09-01 22:35 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2015-08-19 15:22:44 UTC

    
Comment 1 Jonathan Druart 2015-08-19 15:25:52 UTC Comment hidden (obsolete)
Comment 2 j.kylmala 2015-08-20 08:10:31 UTC Comment hidden (obsolete)
Comment 3 Katrin Fischer 2015-09-01 22:35:36 UTC
Created attachment 42186 [details] [review]
[PASSED QA] Bug 14696: useless use of String::Random in catalogue/search.pl

Bug 10404 adds the use of String::Random to catalogue/search.pl but bug
11369 removes it without removing the import line.

Test plan:
  git grep String::Random catalogue/search.pl
should not return anything

Signed-off-by: Joonas Kylmälä <j.kylmala@gmail.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 4 Katrin Fischer 2015-09-01 22:37:04 UTC
It looks like this had been added as part of 762c3304 (Bug 10404 - add previous/next browsing to staff client), but the code has since changed and I couldn't spot a regression.
Comment 5 Tomás Cohen Arazi 2015-09-02 14:10:33 UTC
Patch pushed to master.

Thanks Jonathan!
Comment 6 Liz Rea 2015-09-22 02:15:43 UTC
Pushed to 3.18.x will be in 3.18.11.