Bug 14700 - batch_id is not correctly populated on patron card creation
Summary: batch_id is not correctly populated on patron card creation
Status: RESOLVED DUPLICATE of bug 14739
Alias: None
Product: Koha
Classification: Unclassified
Component: Label/patron card printing (show other bugs)
Version: master
Hardware: All All
: P3 minor (vote)
Assignee: Barton Chittenden
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-08-20 13:53 UTC by Barton Chittenden
Modified: 2015-08-27 12:23 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Barton Chittenden 2015-08-20 13:53:20 UTC
To replicate problem:

1) Navigate to cgi-bin/koha/patroncards/home.pl
2) Click 'New Batch' this will take you to cgi-bin/koha/patroncards/edit-batch.pl?op=new
3) Click 'Add Item(s)' -> opens pop up koha/patroncards/members-search.pl?batch_id=0
4) Search for a patron
5) Click 'add' on that borrower, edit-batch.pl updates to: cgi-bin/koha/patroncards/edit-batch.pl?op=add&batch_id=0&borrower_number=xxxxxx

the header on the edit-items screen shows "Items in batch number " ... this should read "Items in batch number YYYY" -- the batch number is not populated.

It is impossible to export the batch. Clicking back into manage batches *will* show a valid batch number and allow the batch to be exported, but we've broken the batch id on the batch creator page.
Comment 1 Nick Clemens 2015-08-27 12:23:07 UTC

*** This bug has been marked as a duplicate of bug 14739 ***