Bug 14726 - Title not showing up on checkout summary
Summary: Title not showing up on checkout summary
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P5 - low minor (vote)
Assignee: Blou
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-08-25 14:53 UTC by Blou
Modified: 2016-06-21 21:38 UTC (History)
10 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 14726 - Checkout summary doesn't show title (1.50 KB, patch)
2015-09-02 14:04 UTC, Blou
Details | Diff | Splinter Review
Bug 14726 - Checkout summary doesn't show title Right after checking out, a small box appear with "Checkout out: Some Title (32154001669305). Due on 24/09/2015". The title doesn't appear anymore (since the move to db schemas). This fixes it. (1.67 KB, patch)
2015-09-04 08:33 UTC, Andreas Hedström Mace
Details | Diff | Splinter Review
Bug 14726 - Checkout summary doesn't show title (1.79 KB, patch)
2015-09-04 08:45 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Blou 2015-08-25 14:53:28 UTC
When doing a checkout, there's normally a summary just below the blue block, with something like 

Checked out: Some Title (32154001669305). Due on 24/09/2015

Since the move to Schemas, this doesn't show anymore.  This is caused by the line in circulation.tt

[% IF ( issue ) %]
    <div class="lastchecked">
        <p><strong>Checked out: </strong>[% issue.item.biblio.title %] ([%
issue.item.barcode %]). Due on [% issue.date_due | $KohaDates %]</p>
    </div>
[% END %]

issue.item.biblio.title does not resolve.
Comment 1 Blou 2015-09-02 14:04:13 UTC Comment hidden (obsolete)
Comment 2 Andreas Hedström Mace 2015-09-04 08:33:44 UTC Comment hidden (obsolete)
Comment 3 Jonathan Druart 2015-09-04 08:45:39 UTC
Created attachment 42383 [details] [review]
Bug 14726 - Checkout summary doesn't show title

Right after checking out, a small box appear with "Checkout out: Some Title (32154001669305). Due on 24/09/2015".
The title doesn't appear anymore (since the move to db schemas). This fixes it.

Test:
1) checkout ANY item, for ANY user
2) Look at summary right below the checkout input box.  The title doesn't show up.
3) apply patch, reproduce same steps (after checkin if same item).  Title appears.

Signed-off-by: Andreas Hedström Mace <andreas.hedstrom.mace@sub.su.se>
Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Todo: You need to track what are the queries generated here.
Comment 4 Tomás Cohen Arazi 2015-09-07 14:59:02 UTC
Patch pushed to master.

Thanks Blou!
Comment 5 Chris Cormack 2015-09-22 02:04:57 UTC
Pushed to 3.20.x will be in 3.20.4
Comment 6 Liz Rea 2015-09-22 04:48:45 UTC
Pushed to 3.18.x, will be in 3.18.11.

Resolved minor conflict for 3.18.