Bug 14800 - Adding Patrons to new Batch increments batchno instead of adding patron to list
Summary: Adding Patrons to new Batch increments batchno instead of adding patron to list
Status: RESOLVED DUPLICATE of bug 14739
Alias: None
Product: Koha
Classification: Unclassified
Component: Tools (show other bugs)
Version: 3.20
Hardware: All All
: P5 - low normal (vote)
Assignee: Galen Charlton
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-09 21:06 UTC by Heinrich Hartl
Modified: 2015-09-10 11:07 UTC (History)
1 user (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
manage batch - after once new batch and add items adding three patrons (62.01 KB, image/jpeg)
2015-09-09 21:06 UTC, Heinrich Hartl
Details
pop up message after trying delete with several batches selected (81.18 KB, image/jpeg)
2015-09-09 21:17 UTC, Heinrich Hartl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Heinrich Hartl 2015-09-09 21:06:46 UTC
Created attachment 42471 [details]
manage batch - after once new batch and add items  adding three patrons

I observed the following malfunction in 3.20:

In pataron card creator after choosing new batch:
By Add Item(s) I am offered a pop up window to search for patrons. In each row of all the patrons found for this search there is a button to add this patron to the (new) batch. After pressing this button the patron is really added to the new batch which now comprises just this one. If I want to add more patrons to the list and therefore continue  e.g. with another search and pressing add for further patrons to be included in the batch the chosen patrons are not added to the just created batch but instead new batches are crated and I end with several new batches each one with exactly one patron in it!


Apparently this is not so if  i chose to edit an existing batch. Add item(s) and adding several patrons results correctly in extending the current batch. This is also my bypass for the problem. I created a batch with the first patron in it, returned to manage batches, chose again the just created batch for editing an could complement it with the other wanted patrons.
Comment 1 Heinrich Hartl 2015-09-09 21:14:16 UTC
Unfortunately I had created about 20 batches when trying to print patron cards for 20 new patrons. Deleting these was no fun - After selecting these batches for deletion I was told that I can delete only one batch at a time, SO what for is the possibility to select more batches?
Comment 2 Heinrich Hartl 2015-09-09 21:17:11 UTC
Created attachment 42472 [details]
pop up message after trying  delete with several batches selected
Comment 3 Nick Clemens 2015-09-10 11:07:41 UTC

*** This bug has been marked as a duplicate of bug 14739 ***