Bug 14829 - Wrong shortcuts in module "cataloging"
Summary: Wrong shortcuts in module "cataloging"
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: master
Hardware: All All
: P5 - low minor (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-15 22:50 UTC by Michael Kuhn
Modified: 2016-06-21 21:40 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 14829: Fix shortcuts in the cataloging and patron modules (3.62 KB, patch)
2015-09-16 08:04 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 14829: Fix shortcuts in the cataloging and patron modules (3.67 KB, patch)
2015-09-16 11:01 UTC, Josef Moravec
Details | Diff | Splinter Review
[PASSED QA] Bug 14829: Fix shortcuts in the cataloging and patron modules (3.74 KB, patch)
2015-09-30 21:35 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Kuhn 2015-09-15 22:50:58 UTC
There are three shortcuts or hotkeys in the Koha staff client:

* Alt + U = Check out
* Alt + R = Check in
* Alt + Q = Search the catalog

As I understand these shortcuts should work all over the staff client, and mostly they do. In Koha 3.20 though when going to Koha menu "Cataloging" they don't work as expected. Instead here the mapping is:

* Alt + U = Search the catalog
* Alt + R = Cataloging search
* Alt + Q = Check out
Comment 1 Jonathan Druart 2015-09-16 08:04:58 UTC Comment hidden (obsolete)
Comment 2 Michael Kuhn 2015-09-16 10:31:34 UTC
I applied the patch manually in the files "cataloging-search.inc" and "patron-search.inc" of directory "/usr/share/koha/intranet/htdocs/intranet-tmpl/prog/de-DE/includes" and the patch works as expected.
Comment 3 Josef Moravec 2015-09-16 11:01:33 UTC Comment hidden (obsolete)
Comment 4 Liz Rea 2015-09-17 03:25:29 UTC
You might check the serials module tabs as well. :)
Comment 5 Jonathan Druart 2015-09-17 06:47:17 UTC
(In reply to Liz Rea from comment #4)
> You might check the serials module tabs as well. :)

Yes, it looks good. But, even without this patch :)
Why did you say that?
Comment 6 Liz Rea 2015-09-17 20:32:22 UTC
Because when I was looking at it the other day, it seemed like it was acting weirdly, but I take your word for it that it's ok. :)
Comment 7 Katrin Fischer 2015-09-30 21:35:20 UTC
Created attachment 42981 [details] [review]
[PASSED QA] Bug 14829: Fix shortcuts in the cataloging and patron modules

In these 2 modules, the shortcuts alt+q, alt+r and alt+u don't work as
in other modules.
The tab are not "built" in the correct order and the id returned to
select the correct tab is wrong.

Test plan:
Go on the circ home page (circ/circulation-home.pl), the patron home
page (members/members-home.pl) and the cataloging home page
(cataloguing/addbooks.pl).
On these 3 pages, without this patch, the shortcuts select different
tabs.
With this patch, the issue is fixed for all of them.

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 8 Tomás Cohen Arazi 2015-10-02 18:28:52 UTC
Patch pushed to master.

Thanks Jonathan!