Bug 14836 - Move the patron categories related code to Koha::Patron::Categories - part 1
Summary: Move the patron categories related code to Koha::Patron::Categories - part 1
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
: 10804 16195 (view as bug list)
Depends on:
Blocks: 15449 6906 15407
  Show dependency treegraph
 
Reported: 2015-09-16 15:49 UTC by Jonathan Druart
Modified: 2016-12-05 21:27 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Medium patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 14836: Add Koha::PatronCategor[y|ies] classes (6.55 KB, patch)
2015-09-16 15:56 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 14836: Use Koha::PatronCategor[y|ies] in admin/categories.pl (61.04 KB, patch)
2015-09-16 15:56 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 14836: Use Koha::PatronCategor[y|ies] in admin/categories.pl (61.15 KB, patch)
2015-10-27 11:37 UTC, Frédéric Demians
Details | Diff | Splinter Review
Bug 14836: Use Koha::PatronCategor[y|ies] in admin/categories.pl (61.15 KB, patch)
2015-10-27 11:38 UTC, Frédéric Demians
Details | Diff | Splinter Review
Bug 14836: Add Koha::PatronCategor[y|ies] classes (6.60 KB, patch)
2015-10-27 11:40 UTC, Frédéric Demians
Details | Diff | Splinter Review
Bug 14836: Use Koha::PatronCategor[y|ies] in admin/categories.pl (61.39 KB, patch)
2015-10-29 09:09 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 14836: Add Koha::PatronCategor[y|ies] classes (6.60 KB, patch)
2015-10-29 09:09 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 14836: Move Koha::PatronCategor* to Koha::Patron::Categor* (4.38 KB, patch)
2015-10-29 09:09 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 14836: Add tests for Koha::Patron::Categor[y|ies] (2.71 KB, patch)
2015-10-29 09:09 UTC, Jonathan Druart
Details | Diff | Splinter Review
[PASSED QA] Bug 14836: Use Koha::PatronCategor[y|ies] in admin/categories.pl (61.46 KB, patch)
2015-10-30 18:57 UTC, Kyle M Hall
Details | Diff | Splinter Review
[PASSED QA] Bug 14836: Use Koha::PatronCategor[y|ies] in admin/categories.pl (61.46 KB, patch)
2015-10-30 18:57 UTC, Kyle M Hall
Details | Diff | Splinter Review
[PASSED QA] Bug 14836: Add Koha::PatronCategor[y|ies] classes (6.68 KB, patch)
2015-10-30 18:57 UTC, Kyle M Hall
Details | Diff | Splinter Review
[PASSED QA] Bug 14836: Move Koha::PatronCategor* to Koha::Patron::Categor* (4.45 KB, patch)
2015-10-30 18:57 UTC, Kyle M Hall
Details | Diff | Splinter Review
[PASSED QA] Bug 14836: Add tests for Koha::Patron::Categor[y|ies] (2.79 KB, patch)
2015-10-30 18:58 UTC, Kyle M Hall
Details | Diff | Splinter Review
[PASSED QA] Bug 14836 [QA Followup] - Fix number of unit tests (869 bytes, patch)
2015-10-30 18:58 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 14836: (QA followup) Add missing transaction (1.47 KB, patch)
2015-11-05 14:09 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2015-09-16 15:49:36 UTC

    
Comment 1 Jonathan Druart 2015-09-16 15:56:11 UTC Comment hidden (obsolete)
Comment 2 Jonathan Druart 2015-09-16 15:56:17 UTC Comment hidden (obsolete)
Comment 3 Frédéric Demians 2015-10-27 11:37:48 UTC Comment hidden (obsolete)
Comment 4 Frédéric Demians 2015-10-27 11:38:46 UTC Comment hidden (obsolete)
Comment 5 Frédéric Demians 2015-10-27 11:40:14 UTC Comment hidden (obsolete)
Comment 6 Katrin Fischer 2015-10-29 07:13:49 UTC
*** Bug 10804 has been marked as a duplicate of this bug. ***
Comment 7 Jonathan Druart 2015-10-29 09:09:09 UTC Comment hidden (obsolete)
Comment 8 Jonathan Druart 2015-10-29 09:09:12 UTC Comment hidden (obsolete)
Comment 9 Jonathan Druart 2015-10-29 09:09:15 UTC Comment hidden (obsolete)
Comment 10 Jonathan Druart 2015-10-29 09:09:18 UTC Comment hidden (obsolete)
Comment 11 Kyle M Hall 2015-10-30 18:57:29 UTC Comment hidden (obsolete)
Comment 12 Kyle M Hall 2015-10-30 18:57:50 UTC
Created attachment 44251 [details] [review]
[PASSED QA] Bug 14836: Use Koha::PatronCategor[y|ies] in admin/categories.pl

Test plan:
Add/edit/remove patron categories from the administration module
(admin/categories.pl).
You should get message feedback after each action.

Signed-off-by: Frederic Demians <f.demians@tamil.fr>
  Operations in admin/category is unchanged, and functionnal

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 13 Kyle M Hall 2015-10-30 18:57:57 UTC
Created attachment 44252 [details] [review]
[PASSED QA] Bug 14836: Add Koha::PatronCategor[y|ies] classes

Note that some of the routines are retrieved from bug 10363 (branch
limitations).
They are not all used in these patch set, but they will permit to
replace the subroutines in C4::Form::MessagingPreferences, in the next
step.

Signed-off-by: Frederic Demians <f.demians@tamil.fr>

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 14 Kyle M Hall 2015-10-30 18:57:59 UTC
Created attachment 44253 [details] [review]
[PASSED QA] Bug 14836: Move Koha::PatronCategor* to Koha::Patron::Categor*

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 15 Kyle M Hall 2015-10-30 18:58:02 UTC
Created attachment 44254 [details] [review]
[PASSED QA] Bug 14836: Add tests for Koha::Patron::Categor[y|ies]

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 16 Kyle M Hall 2015-10-30 18:58:05 UTC
Created attachment 44255 [details] [review]
[PASSED QA] Bug 14836 [QA Followup] - Fix number of unit tests

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 17 Tomás Cohen Arazi 2015-11-05 14:09:21 UTC
Created attachment 44519 [details] [review]
Bug 14836: (QA followup) Add missing transaction

Bug 15081 removed transaction handling from t::lib::TestBuilder so this
patchset had to be ammended to handle it on its own.

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>
Comment 18 Tomás Cohen Arazi 2015-11-05 14:10:01 UTC
Patches pushed to master.

Thanks Jonathan!
Comment 19 Alex Sassmannshausen 2016-04-11 11:50:52 UTC
*** Bug 16195 has been marked as a duplicate of this bug. ***