Bug 14841 - Columns settings on checkouts table have 2 bugs
Summary: Columns settings on checkouts table have 2 bugs
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
: 14657 (view as bug list)
Depends on: 9481 13492
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-17 07:34 UTC by Jonathan Druart
Modified: 2016-12-05 21:27 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 14841: Columns settings are not taken into account for checkout table / moremember (1.77 KB, patch)
2015-09-17 07:44 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 14841: Fine column is not manage by columns settings (1.10 KB, patch)
2015-09-17 07:44 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 14841: Columns settings are not taken into account for checkout table / moremember (1.91 KB, patch)
2015-10-05 07:39 UTC, j.kylmala
Details | Diff | Splinter Review
Bug 14841: Fine column is not manage by columns settings (1.25 KB, patch)
2015-10-05 07:40 UTC, j.kylmala
Details | Diff | Splinter Review
Bug 14841: Columns settings are not taken into account for checkout table / moremember (1.91 KB, patch)
2015-10-12 05:22 UTC, Katrin Fischer
Details | Diff | Splinter Review
[PASSED QA] Bug 14841: Fine column is not manage by columns settings (1.32 KB, patch)
2015-10-12 05:22 UTC, Katrin Fischer
Details | Diff | Splinter Review
[PASSED QA] Bug 14841: Columns settings are not taken into account for checkout table / moremember (1.98 KB, patch)
2015-10-12 05:23 UTC, Katrin Fischer
Details | Diff | Splinter Review
[PASSED QA] Bug 14841: Fine column is not manage by columns settings (1.32 KB, patch)
2015-10-12 05:23 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2015-09-17 07:34:02 UTC
1/ The settings defined on the administration page are not taken into account
2/ The "Fines" column does not appear in the field list.
Comment 1 Jonathan Druart 2015-09-17 07:44:11 UTC Comment hidden (obsolete)
Comment 2 Jonathan Druart 2015-09-17 07:44:14 UTC Comment hidden (obsolete)
Comment 3 Jonathan Druart 2015-09-17 07:45:52 UTC
Bugs 9481 and 13492 are in 3.20.x, this should be backported.
Comment 4 j.kylmala 2015-10-05 07:39:04 UTC Comment hidden (obsolete)
Comment 5 j.kylmala 2015-10-05 07:40:27 UTC Comment hidden (obsolete)
Comment 6 Katrin Fischer 2015-10-12 05:22:05 UTC Comment hidden (obsolete)
Comment 7 Katrin Fischer 2015-10-12 05:22:16 UTC Comment hidden (obsolete)
Comment 8 Katrin Fischer 2015-10-12 05:23:11 UTC
Created attachment 43323 [details] [review]
[PASSED QA] Bug 14841: Columns settings are not taken into account for checkout table / moremember

There is a typo member vs members in the template when retrieving the
existing settings.
So that all columns are displayed, even the ones which are hidden
(sort_order, due_date_unformatted, etc.)

Test plan:
0/ Does not apply this patch
1/ Go on the columns config page and check some fields not to display by
default for Patrons > moremember > issues-table
2/ Go on the patron detail page (with checkouts), click on the "show/hide
columns" button (top right of the table).
Confirm that the config is not taken into account and that it's ugly
(hidden columns are displayed)
3/ Apply this patch
4/ Everything should be fine now :)

Signed-off-by: Joonas Kylmälä <j.kylmala@gmail.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 9 Katrin Fischer 2015-10-12 05:23:33 UTC
Created attachment 43324 [details] [review]
[PASSED QA] Bug 14841: Fine column is not manage by columns settings

Bug 9481 added the "Fine" columns to the checkouts table and bug 13492
added the columns settings to these table.
They overlapped each others in the bugs queue.

Test plan:
Confirm that you are able to hide/show the "Fine" columns on both
checkouts table.

Signed-off-by: Joonas Kylmälä <j.kylmala@gmail.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 10 Tomás Cohen Arazi 2015-10-13 15:16:34 UTC
Patches pushed to master.

Thanks Jonathan!
Comment 11 Jonathan Druart 2016-04-05 06:21:48 UTC
*** Bug 14657 has been marked as a duplicate of this bug. ***
Comment 12 Jonathan Druart 2016-04-05 06:22:59 UTC
(In reply to Jonathan Druart from comment #3)
> Bugs 9481 and 13492 are in 3.20.x, this should be backported.

That bug still exists on 3.20.x (see bug 14657).
Comment 13 Frédéric Demians 2016-04-05 07:28:09 UTC
Pushed to 3.20.x. Will be in 3.20.11. Thanks Jonathan.