Bug 14867 - userid not generated when defined in BorrowerUnwantedField
Summary: userid not generated when defined in BorrowerUnwantedField
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Patrons (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Fridolin SOMERS
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-22 07:54 UTC by Fridolin SOMERS
Modified: 2017-06-14 22:05 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 14867 - userid not generated when defined in BorrowerUnwantedField (2.22 KB, patch)
2015-09-22 08:05 UTC, Fridolin SOMERS
Details | Diff | Splinter Review
Bug 14867 - userid not generated when defined in BorrowerUnwantedField (2.22 KB, patch)
2015-09-22 08:19 UTC, Fridolin SOMERS
Details | Diff | Splinter Review
Bug 14867 - userid not generated when defined in BorrowerUnwantedField (2.42 KB, patch)
2015-11-03 05:46 UTC, Frédéric Demians
Details | Diff | Splinter Review
[PASSED QA] Bug 14867 - userid not generated when defined in BorrowerUnwantedField (2.49 KB, patch)
2015-11-06 13:08 UTC, Kyle M Hall
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Fridolin SOMERS 2015-09-22 07:54:42 UTC
When userid is not provided when creating a new patron, it is generated using surname and firstname.
The bug is when userid is defined in syspref BorrowerUnwantedField, the input text is missing in patron creation form. When saving you always get an alert message : "Username/password already exists". No patron can be created.
Comment 1 Fridolin SOMERS 2015-09-22 08:05:05 UTC Comment hidden (obsolete)
Comment 2 Fridolin SOMERS 2015-09-22 08:19:36 UTC Comment hidden (obsolete)
Comment 3 Frédéric Demians 2015-11-03 05:46:50 UTC Comment hidden (obsolete)
Comment 4 Kyle M Hall 2015-11-06 13:08:08 UTC
Created attachment 44554 [details] [review]
[PASSED QA] Bug 14867 - userid not generated when defined in BorrowerUnwantedField

When userid is not provided when creating a new patron, it is generated
using surname and firstname.  The bug is when userid is defined in
syspref BorrowerUnwantedField, the input text is missing in patron
creation form. When saving you always get an alert message :
"Username/password already exists". No patron can be created.

This patch corrects by adding this case to userid generation conditions.

Test plan :
- add 'userid' in syspref BorrowerUnwantedField
- try to create a new patron : /cgi-bin/koha/members/memberentry.pl
- there is not input text for userid
- choose non-existing surname and firstname
- click on save
  => Without patch : patron is not created, you see the alert message
     "Username/password already exists"
  => With patch : patron is created, userid is generated with surname
     and firstname
- remove 'userid' in syspref BorrowerUnwantedField and check it can be
  defined in patron creation form

Signed-off-by: Frédéric Demians <f.demians@tamil.fr>
  The issue is there, and this patch fixes it.

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 5 Tomás Cohen Arazi 2015-11-09 15:53:43 UTC
Patch pushed to master.

Thanks Frido!
Comment 6 Frédéric Demians 2015-11-29 20:43:59 UTC
This patch has been pushed to 3.20.x, will be in 3.20.6.
Comment 7 Liz Rea 2016-01-06 21:20:36 UTC
Pushed to 3.18.13, and released.