Bug 14916 - Overdues are not listed if due on 23:59 of the 'to date' (Was: Remove C4::Dates from circ/overdue.pl)
Summary: Overdues are not listed if due on 23:59 of the 'to date' (Was: Remove C4::Dat...
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 14870
  Show dependency treegraph
 
Reported: 2015-09-28 14:43 UTC by Marc Véron
Modified: 2016-06-21 21:40 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 14916 - Remove C4::Dates from circ/overdue.pl (2.34 KB, patch)
2015-09-28 14:52 UTC, Marc Véron
Details | Diff | Splinter Review
Bug 14916 - Remove C4::Dates from circ/overdue.pl (2.34 KB, patch)
2015-09-28 14:57 UTC, Marc Véron
Details | Diff | Splinter Review
[SIGNED-OFF]Bug 14916 - Remove C4::Dates from circ/overdue.pl (2.46 KB, patch)
2015-10-12 15:47 UTC, Héctor Eduardo Castro Avalos
Details | Diff | Splinter Review
Bug 14916: Display overdues if due on 23:59 (5.74 KB, patch)
2015-10-13 10:24 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 14916: Display overdues if due on 23:59 (5.92 KB, patch)
2015-10-14 17:17 UTC, Marc Véron
Details | Diff | Splinter Review
[PASSED QA] Bug 14916: Display overdues if due on 23:59 (5.98 KB, patch)
2015-10-18 10:55 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Véron 2015-09-28 14:43:13 UTC
Patch to remove deprectated C4::Dates from circ/overdue.pl
Comment 1 Marc Véron 2015-09-28 14:52:52 UTC Comment hidden (obsolete)
Comment 2 Marc Véron 2015-09-28 14:57:37 UTC Comment hidden (obsolete)
Comment 3 Héctor Eduardo Castro Avalos 2015-10-12 15:47:58 UTC Comment hidden (obsolete)
Comment 4 Jonathan Druart 2015-10-13 10:24:38 UTC Comment hidden (obsolete)
Comment 5 Jonathan Druart 2015-10-13 10:25:45 UTC
Marc,
Sorry to steal your bug (again), but I think I have found a bug on master.
Could you please confirm?
Comment 6 Marc Véron 2015-10-14 17:16:28 UTC
Hi Jonathan,

No problem, steal as much as you like :-)

And confirmed, sign-off follows.
Comment 7 Marc Véron 2015-10-14 17:17:37 UTC Comment hidden (obsolete)
Comment 8 Katrin Fischer 2015-10-18 10:55:15 UTC
Created attachment 43567 [details] [review]
[PASSED QA] Bug 14916: Display overdues if due on 23:59

If an item is due today 23:59 and the filter is from yesterday
to today, the overdue won't appear on the list.

Test plan:
Be sure you have an item due on DATE 23:59
Search for overdues from DATE-1 to DATE
Without this patch, the item won't appear.
With this patch, it will.

Regression test: test the CSV download.

Note: On the way, this patch remove the deps to C4::Dates
(which was the original goal of the bug report).

Issue reproduced, it's resolved with this patch.
Signed-off-by: Marc Véron <veron@veron.ch>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 9 Tomás Cohen Arazi 2015-10-19 14:55:22 UTC
Patch pushed to master.

Thanks Jonathan!