Bug 14966 - Table header broken at detail.tt
Summary: Table header broken at detail.tt
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: P5 - low trivial (vote)
Assignee: Rafal Kopaczka
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 15256
  Show dependency treegraph
 
Reported: 2015-10-06 13:19 UTC by Rafal Kopaczka
Modified: 2016-06-21 21:38 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
screenshot (6.77 KB, image/png)
2015-10-06 13:19 UTC, Rafal Kopaczka
Details
Bug 14966:Table header broken at detail.tt (1.42 KB, patch)
2015-10-06 13:21 UTC, Rafal Kopaczka
Details | Diff | Splinter Review
Bug 14966:Table header broken at detail.tt (1.49 KB, patch)
2015-10-06 13:34 UTC, Jonathan Druart
Details | Diff | Splinter Review
[PASSED QA] Bug 14966:Table header broken at detail.tt (1.56 KB, patch)
2015-10-12 05:26 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Rafal Kopaczka 2015-10-06 13:19:11 UTC
Created attachment 43168 [details]
screenshot

After Bug 14354, when user without permission to edit items, goes to page:
/cgi-bin/koha/catalogue/detail.pl?biblionumber=xxx, table with item info is corrupted. See screenshot attached. 
Looks like additional '<td>', are unnecessary.
A patch will follow.
Comment 1 Rafal Kopaczka 2015-10-06 13:21:58 UTC Comment hidden (obsolete)
Comment 2 Jonathan Druart 2015-10-06 13:34:56 UTC Comment hidden (obsolete)
Comment 3 Jonathan Druart 2015-10-09 11:05:36 UTC
This one fixes a regression on stable branches 3.20.x and 3.18.x and should be backported on the next release.
Comment 4 Katrin Fischer 2015-10-12 05:26:39 UTC
Created attachment 43325 [details] [review]
[PASSED QA] Bug 14966:Table header broken at detail.tt

For user without item edit permission, table at catalogue/detail.pl is
corrupted.

Test plan:
1) Log in as staff member, without edit item permission.
2) Go to biblio view, with items attached:
/cgi-bin/koha/catalogue/detail.pl?biblionumber=X. Confirm that table
does not display correctly.
3) Apply patch.
4) Repeat steps 1 and 2. Confirm patch works.

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 5 Tomás Cohen Arazi 2015-10-13 15:22:43 UTC
Patch pushed to master.

Thanks Rafal!
Comment 6 Chris Cormack 2015-10-24 07:41:19 UTC
Pushed to 3.20.x will be in 3.20.5
Comment 7 Liz Rea 2015-11-25 20:33:37 UTC
This was released in 3.18.12 - sorry I missed it when I was updating bugs.

Liz