Bug 14968 - found shouldn't be set to null when cancelling holds
Summary: found shouldn't be set to null when cancelling holds
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Hold requests (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Koha Team University Lyon 3
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-06 13:42 UTC by Koha Team University Lyon 3
Modified: 2017-12-07 22:15 UTC (History)
9 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Text to go in the release notes:
Version(s) released in:


Attachments
found shouldn't be set to null when cancelling holds (695 bytes, patch)
2015-10-06 13:51 UTC, Koha Team University Lyon 3
Details | Diff | Splinter Review
Bug 14968 - found shouldn't be set to null when cancelling holds (753 bytes, patch)
2015-12-17 14:41 UTC, sandboxes@biblibre.com
Details | Diff | Splinter Review
Bug 14968 - Provides unit test (1.14 KB, patch)
2016-06-15 14:13 UTC, Alex Arnaud
Details | Diff | Splinter Review
Bug 14968 - found shouldn't be set to null when cancelling holds (811 bytes, patch)
2016-06-29 08:35 UTC, sandboxes@biblibre.com
Details | Diff | Splinter Review
Bug 14968 - Provides unit test (1.20 KB, patch)
2016-06-29 08:35 UTC, sandboxes@biblibre.com
Details | Diff | Splinter Review
Bug 14968 - found shouldn't be set to null when cancelling holds (879 bytes, patch)
2016-07-01 14:34 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 14968 - Provides unit test (1.27 KB, patch)
2016-07-01 14:34 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Koha Team University Lyon 3 2015-10-06 13:42:25 UTC
We want to provide statistics on canceled holds to know if they haven't been picked-up while waiting for the borrower or if the expiration_date on hold have been passed.
But if we can see if a hold is waiting in found column of reserves table, this information disappeared from old_reserves table.

Found shouldn't be set to Null when cancelling in order to keep this information in old_reserves.
Comment 1 Koha Team University Lyon 3 2015-10-06 13:51:46 UTC Comment hidden (obsolete)
Comment 2 Koha Team University Lyon 3 2015-10-06 15:54:49 UTC
Test plan :
- fill syspref ReservesMaxPickUpDelay = 0
- Add a hold and return the item to make it waiting for the borrower 
- Wait one day or change waitingdate in reserves table to put yesterday date
- launch the script /src/misc/cronjobs/holds/cancel_expired_holds.pl

You should find your reserve in old_rerseves table with W in column found
Comment 3 sandboxes@biblibre.com 2015-12-17 14:41:14 UTC
Patch tested with a sandbox, by JM Broust <jean-manuel.broust@univ-lyon2.fr>
Comment 4 sandboxes@biblibre.com 2015-12-17 14:41:32 UTC Comment hidden (obsolete)
Comment 5 Jonathan Druart 2016-01-14 12:54:25 UTC
Please provide a regression test for this change and provide use case.
Why do you want to look at this value when the reserve has been removed (just a curious question :))?
Comment 6 Katrin Fischer 2016-01-14 13:32:39 UTC
Hi Jonathan, I think it's for statistics: filled vs. cancelled holds.
Comment 7 Koha Team University Lyon 3 2016-01-19 16:21:28 UTC
Yes, we want to have statistics to know if holds have been cancelled because they have never been available or because they've not been picked up by the borrower.

We can also imagine having different notices to warn borrowers that their holds have been cancelled : text can be different if the document isn't available or if the document was waiting but the borrowers didn't come to take it in time.
Comment 8 Alex Arnaud 2016-06-15 14:13:27 UTC Comment hidden (obsolete)
Comment 9 sandboxes@biblibre.com 2016-06-29 08:35:18 UTC
Patch tested with a sandbox, by Broust <jean-manuel.broust@univ-lyon2.fr>
Comment 10 sandboxes@biblibre.com 2016-06-29 08:35:47 UTC Comment hidden (obsolete)
Comment 11 sandboxes@biblibre.com 2016-06-29 08:35:50 UTC Comment hidden (obsolete)
Comment 12 Jonathan Druart 2016-07-01 14:34:52 UTC
Created attachment 53015 [details] [review]
Bug 14968 - found shouldn't be set to null when cancelling holds

Signed-off-by: JM Broust <jean-manuel.broust@univ-lyon2.fr>

Signed-off-by: Broust <jean-manuel.broust@univ-lyon2.fr>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 13 Jonathan Druart 2016-07-01 14:34:56 UTC
Created attachment 53016 [details] [review]
Bug 14968 - Provides unit test

Signed-off-by: Broust <jean-manuel.broust@univ-lyon2.fr>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 14 Kyle M Hall 2016-07-08 12:44:31 UTC
Pushed to master for 16.11, thanks Lyon 3, Alex!
Comment 15 Frédéric Demians 2016-08-01 13:20:33 UTC
Pushed in 16.05. Will be in 16.05.02.
Comment 16 Julian Maurice 2016-08-16 14:10:46 UTC
Patches pushed to 3.22.x, will be in 3.22.10