Bug 15014 - Plack testing -- Import patrons tool -- sample text file link broken
Summary: Plack testing -- Import patrons tool -- sample text file link broken
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Tools (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 15019
  Show dependency treegraph
 
Reported: 2015-10-15 14:53 UTC by HB-NEKLS
Modified: 2017-06-14 22:11 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 15014: Returns 0 if everything went fine (977 bytes, patch)
2015-10-16 09:04 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 15014: Returns 0 if everything went fine (1.03 KB, patch)
2015-10-23 07:01 UTC, Josef Moravec
Details | Diff | Splinter Review
Bug 15014: Returns 0 if everything went fine (1.11 KB, patch)
2015-11-04 16:34 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description HB-NEKLS 2015-10-15 14:53:20 UTC
To recreate: 

1. Go to Tools --> Import Patrons
2. Click on the "here" link under notes (Download a starter CSV file with all the columns here.)
3. Note the Internal Server Error for this link http://test-intra.plack.bywatersolutions.com/cgi-bin/koha/tools/import_borrowers.pl?sample=1

That's the old link, right?
Comment 1 Jonathan Druart 2015-10-16 08:58:08 UTC
Will be fixed by

Subject: [PATCH] Bug 15005: Replace $ENV{SCRIPT_NAME} with the hardcoded script paths

*** This bug has been marked as a duplicate of bug 15005 ***
Comment 2 Jonathan Druart 2015-10-16 08:59:37 UTC
No it's not!
Comment 3 Jonathan Druart 2015-10-16 09:04:08 UTC Comment hidden (obsolete)
Comment 4 Josef Moravec 2015-10-23 07:01:16 UTC Comment hidden (obsolete)
Comment 5 Tomás Cohen Arazi 2015-11-04 16:34:02 UTC
Created attachment 44429 [details] [review]
Bug 15014: Returns 0 if everything went fine

Be kind and return 0 if the sample file has been generated correctly.
Otherwise you are a bad guy and you make Plack returns an internal error
(exited nonzero: 1 at /home/vagrant/kohaclone/tools/import_borrowers.pl line 390.)

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Works as expected
Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>
Works as expected here too.
Comment 6 Tomás Cohen Arazi 2015-11-04 16:43:35 UTC
Patch pushed to master.

Thanks Jonathan!
Comment 7 Frédéric Demians 2015-11-29 20:17:17 UTC
This patch has been pushed to 3.20.x, will be in 3.20.6.