Bug 15040 - Plack testing -- patron files area not behaving as expected
Summary: Plack testing -- patron files area not behaving as expected
Status: CLOSED WORKSFORME
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks: 15019
  Show dependency treegraph
 
Reported: 2015-10-20 21:40 UTC by HB-NEKLS
Modified: 2016-06-21 21:37 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description HB-NEKLS 2015-10-20 21:40:52 UTC
I'm checking the patron file upload with Plack, and seeing something odd; this may or may not be Plack-related. First, I set the patronimages & EnableBorrowerFiles sys prefs to Allow/Do. Here's the oddity I've run into so far (the other one went away while writing the bug report):

When I can finally get the Files tab up, the system says the patron has no files attached -- even though I've uploaded 2 files already. But if I upload another file, the now three attached files display, but if I click away from the files area, and come back, the system says the patron has no files attached, yet again. 

The borrower I was working with: http://test-intra.plack.bywatersolutions.com/cgi-bin/koha/members/files.pl?borrowernumber=102
Comment 1 Josef Moravec 2015-10-26 09:25:01 UTC
I can't reproduce it, everything around upload patron files works as expected for me... So I'm closing it. If you think it's still valid, please reopen.